Bug 500202 - Provisioning, non-xen-guest kickstarts hang at end of install due to cobbler snippet post_install_network_config
Provisioning, non-xen-guest kickstarts hang at end of install due to cobbler ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
na
:
Depends On:
Blocks: 457075 486216
  Show dependency treegraph
 
Reported: 2009-05-11 12:53 EDT by wes hayutin
Modified: 2009-09-10 14:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-05-11 12:53:54 EDT
Description of problem:

sat 5/7.1 build on rhel 5.

recreate:
1. register a rhel 4 or rhel 5 system
2. create a regular (non xen/kvm) ks profile
3. kickstart the box

results.. hangs at the very end after starting rhnd

work around, console in and reboot

expected results:  kickstart completes


speaking w/ Justin, one of the snippets is waiting for some data.
cobbler/snippets/post_install_networking_config

looks like the prob is around line 100 w/ modprobe and the interface name
Comment 1 Justin Sherrill 2009-05-11 13:47:28 EDT
So this was fixed upstream in cobbler (commit 93bb34c0), need to track it down and see why it's not in webqa.
Comment 2 Justin Sherrill 2009-05-11 18:03:39 EDT
To clarify the steps to reproduce:

1.   Register a RHEL 5 machine and set it up as a virt host (making sure that the xen kernel is booted)

2.  Try to re-provision the machine.

3.  %post section will hang
Comment 3 Justin Sherrill 2009-05-18 12:03:45 EDT
patch backported in 3rd party git:

731308dea6c946d466606dbb11cd58a3c0a6e259
3b2a5391920d72fad647787a876cad2f142163d1
Comment 4 wes hayutin 2009-05-26 14:15:41 EDT
verified 5/21.1
Comment 5 Tomas Lestach 2009-09-10 07:24:56 EDT
Followed test plan from Comment#2.
(I re-provisioned the xen host twice
 - once to achieve virt host (1)
 - 2nd time to do step (2)

Successfully re-provisioned a xen host in both cases. Machine didn't hang and after every ks it was ready to use.

Right after ks:
# uname -r
2.6.18-164.el5xen
# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      878     2 r-----     27.9

Stage validated -> RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 14:16:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.