Bug 500231 - RFE: quota support for ext4 in RHEL5
RFE: quota support for ext4 in RHEL5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: quota (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Petr Pisar
Martin Cermak
: FutureFeature
Depends On: 469127
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 15:19 EDT by Eric Sandeen
Modified: 2011-01-13 17:10 EST (History)
11 users (show)

See Also:
Fixed In Version: quota-3.13-3.el5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 469127
Environment:
Last Closed: 2011-01-13 17:10:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ext4 patch for quota (1.70 KB, patch)
2009-11-19 16:44 EST, Eric Sandeen
no flags Details | Diff

  None (edit)
Description Eric Sandeen 2009-05-11 15:19:19 EDT
+++ This bug was initially created as a clone of Bug #469127 +++

quota-tools currently only recognizes the "ext4dev" fileystem type; it's a trivial change to support ext4 as well, patch at:

http://marc.info/?l=linux-fsdevel&m=122532700130950&w=2

Thanks,
-Eric

--- Additional comment from ovasik@redhat.com on 2008-10-30 02:09:20 EDT ---

Thanks for report and detailed informations. I don't see that patch reported upstream, so will do that ... and of course will include it to Fedora - as it looks ok and helpful.


----------

Whoops, looks like we need this for RHEL5 as well.  Maybe too late (?) for 5.4 but wanted to at least get it on the radar.

Thanks,
-Eric
Comment 1 Ondrej Vasik 2009-05-11 15:28:17 EDT
Yep, I guess it's too late for 5.4 ... Issue tracker would be good to increase chance to get it into 5.5 ...
Comment 2 Eric Sandeen 2009-05-11 15:33:26 EDT
It's ok, quota isn't really working too well kernelside yet either in RHEL5 ;)  but needed to track this.

Thanks,
-Eric
Comment 3 Eric Sandeen 2009-11-19 16:25:20 EST
And, maybe too late for RHEL5.5 as well now ... is quota already on the package list for 5.5, by any chance?

-Eric
Comment 4 Eric Sandeen 2009-11-19 16:44:27 EST
Created attachment 372344 [details]
ext4 patch for quota

Here's a patch, pretty trivial really.

Thanks,
-Eric
Comment 9 Didier 2010-06-11 05:57:05 EDT
Is there any status update on this, in the light of RHEL5.5 ?
Comment 10 Ondrej Vasik 2010-06-11 07:20:14 EDT
Bugzilla is just bug tracker - not support tool - updates in RHEL are primarily based on support requests, if you want to raise chances of having quota update in RHEL-5 anytime "soon", please contact https://www.redhat.com/apps/support/ . Please inform them about existing bugzilla.
Comment 11 Didier 2010-06-11 08:47:47 EDT
I understand, but :
the BZ 'Version' entry still contains "5.4", hence my confusion.

Should this not be updated if this issue still aplies to 5.5 ?


(as a sidenote, it looks like RHEL 'Academic Edition' subscribers are unable to create Technical Support tickets)
Comment 20 Alan 2010-09-09 19:06:14 EDT
looks like this is also a duplicate of bug 472050

would be really nice to have quota support for ext4 in RHEL 5.5...unable to use ext4 otherwise :(
Comment 21 Petr Pisar 2010-09-13 04:15:24 EDT
(In reply to comment #20)
> looks like this is also a duplicate of bug 472050
> 
RHEL and Fedora do not share packages. Thus separate bug reports exist.

> would be really nice to have quota support for ext4 in RHEL 5.5...unable to use
> ext4 otherwise :(

Fixed package is scheduled for RHEL-5.6.

If you want separate fix for RHEL-5.5, ask Global Support Service.
Comment 22 Eric Sandeen 2010-09-13 10:36:00 EDT
Alan, the ext4 code in RHEL5.5 will not properly support quotas.

However, please do RHEL5.6 test kernels from http://people.redhat.com/jwilson/el5/219.el5/ (or later) which -should- have the necessary kernelside quota bits in place.

Petr, is there any possibility of putting the updated quota package for RHEL5.6 on your people page for testing in conjunction w/ the test kernel above?

Or, I could do that, if you have no objection.

Thanks,
-Eric
Comment 23 Alan 2010-09-13 23:13:56 EDT
thanks for the input.
I've gone ahead and re-formatted my production partition ext3 and decided to continue with that for the school year.  don't really need any of the features of ext4 at this point anyway, so I guess I can wait.  I appreciate the effort though.
-alan
Comment 24 Didier 2010-09-14 02:23:38 EDT
Just to chime in : I certainly wouldn't mind running a pre-5.6 kernel with quota on 5.5, as long as no discernible data loss or corruption issue is involved.
Comment 25 Petr Pisar 2010-09-14 03:29:55 EDT
(In reply to comment #22)
> Petr, is there any possibility of putting the updated quota package for RHEL5.6
> on your people page for testing in conjunction w/ the test kernel above?
> 
I'm sorry, I'm not allowed to publish not yet released packages. Please, wait for 5.6 release that is coming soon.
Comment 27 errata-xmlrpc 2011-01-13 17:10:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0023.html

Note You need to log in before you can comment on or make changes to this bug.