Bug 500281 - [nouveau] Does not support static screen rotation.
[nouveau] Does not support static screen rotation.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 23:21 EDT by Ding-Yi Chen
Modified: 2009-06-30 17:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.0.12-40.20090528git0c17b87.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 22:42:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.73 KB, text/plain)
2009-05-17 23:01 EDT, Ding-Yi Chen
no flags Details
Xorg.0.log (57.66 KB, text/plain)
2009-05-17 23:02 EDT, Ding-Yi Chen
no flags Details
Screenshot when using xrandr -o left (231.12 KB, image/jpeg)
2009-05-17 23:18 EDT, Ding-Yi Chen
no flags Details

  None (edit)
Description Ding-Yi Chen 2009-05-11 23:21:42 EDT
Description of problem:
Drive nv supports static screen rotation by adding
Option "Rotate" "CCW" (or other orientation) 
in Monitor section of xorg.conf

However, in nouveau, this option is simply ignore.
Indeed, screen rotation is achievable by xrandr, 
but it is slower and more problematic than static rotation.

Version-Release number of selected component (if applicable):
0.0.12-34.20090507git1072103

How reproducible:
Always

Steps to Reproduce:
1. Add Option "Rotate" "CCW" in Monitor section in xorg.conf.
2. startx
  
Actual results:
The rotate option is ignored.

Expected results:
Screen should rotate counter-clockwise.

Additional info:
Comment 2 Matěj Cepl 2009-05-15 20:50:59 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Ding-Yi Chen 2009-05-17 23:01:13 EDT
Created attachment 344365 [details]
xorg.conf
Comment 5 Ding-Yi Chen 2009-05-17 23:02:05 EDT
Created attachment 344366 [details]
Xorg.0.log
Comment 7 Ding-Yi Chen 2009-05-17 23:18:13 EDT
Created attachment 344368 [details]
Screenshot when using xrandr -o left
Comment 9 Ding-Yi Chen 2009-05-18 00:35:35 EDT
Thanks, now the option are recognized,  but still not working.
When given the option "Rotate" "left", the display area shrink as a line at bottom left of screen.
I can tell it successfully enter KDE as the "line" change color, but still not usable at this point.

Regards,
Comment 10 Ben Skeggs 2009-05-18 05:42:14 EDT
Should be fixed in -37, available from http://koji.fedoraproject.org/koji/taskinfo?taskID=1359842.  Can you confirm?
Comment 11 Ding-Yi Chen 2009-05-18 22:05:07 EDT
Looks like the screen rotation problem is fixed, thanks!
Comment 12 Ben Skeggs 2009-05-18 22:42:34 EDT
Great!  Thank you!
Comment 13 Fedora Update System 2009-05-19 19:56:06 EDT
libchewing-0.3.2-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-9.fc10
Comment 14 Fedora Update System 2009-05-19 19:56:15 EDT
libchewing-0.3.2-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-9.fc11
Comment 15 Fedora Update System 2009-05-19 19:56:24 EDT
libchewing-0.3.2-9.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-9.fc9
Comment 16 Ding-Yi Chen 2009-05-19 23:33:08 EDT
Sorry about the mess, I've typed a wrong Bug number in other package.
Comment 17 Fedora Update System 2009-06-17 08:28:46 EDT
xorg-x11-drv-nouveau-0.0.12-39.20090528git0c17b87.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.12-39.20090528git0c17b87.fc11
Comment 18 Fedora Update System 2009-06-26 03:15:48 EDT
libchewing-0.3.2-11.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-11.fc10
Comment 19 Fedora Update System 2009-06-26 03:16:04 EDT
libchewing-0.3.2-11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-11.fc11
Comment 20 Fedora Update System 2009-06-26 03:16:19 EDT
libchewing-0.3.2-11.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-11.fc9
Comment 21 Fedora Update System 2009-06-30 17:38:23 EDT
xorg-x11-drv-nouveau-0.0.12-40.20090528git0c17b87.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.