Bug 50035 - Compress function keeps compressing compressed logs!
Compress function keeps compressing compressed logs!
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: logrotate (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Aaron Brown
http://www.ultra-comm.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 03:16 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 12:58:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-26 03:16:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
This bug is was found in the logrotate utility when using the compress 
configuration specifically the interchange config file located in the 
logrotate.d/interchange which uses the compress function.  Logs located 
in /var/log/interchange were to be rotated and compressed.  Logs rotated 
would have the *.n apended fine. Comprssed logs would have the *.gz 
apended but after each rotation comoressed logs would be also rotated and 
re-compressed and no log limits are recogonized.  Unless manually deleted 
this files will keep growing until logrotate cannot hold all the files in 
memory and is unable to complete and unload from memory.  Session never 
ends and the server eventually crashes. Check it out you will notice a 
*.gz apended over an over on files after each rotation they will get a 
mile long and noting is ever deleted due to this bug.  Since there is only 
one rotation number on rotated logs I'm assuming the bug is in the 
compress logic module which is not looking back before the .gz for the 
rotation number and skiping rotations already compressed.

How reproducible:
Always

Steps to Reproduce:
1.configure a log rotation config file to rotate with compress.
2.for quicker results, rotate daily, and 2 to 4 rotations
3.Check the log folder after the last rotation you notice the results.
	

Actual Results:  each rotation with compress configured rotated, 
compressed and apended the .gz on the end.  Next rotation added re-
compressed each compressed file and added another .gz on the end and as a 
new file with the old still there.  

Additional info:
Comment 1 Elliot Lee 2001-12-28 14:58:15 EST
Would you try the logrotate-3.5.9 in RHL 7.2 (or the logrotate-3.6 in RHL 8.0)
and see if this behaviour still occurs? There have been several
compression-related fixes since RHL 7.0.

Note You need to log in before you can comment on or make changes to this bug.