Bug 500410 - puplet dies with a traceback
puplet dies with a traceback
Status: CLOSED DUPLICATE of bug 480339
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 11:32 EDT by Alexander Todorov
Modified: 2013-04-12 16:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 07:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-05-12 11:32:27 EDT
Description of problem:
$ /usr/bin/puplet 
Introspect error: The name edu.duke.linux.yum was not provided by any .service files
Traceback (most recent call last):
  File "/usr/bin/puplet", line 467, in ?
    main()
  File "/usr/bin/puplet", line 464, in main
    p.run()
  File "/usr/bin/puplet", line 451, in run
    self._refreshInfo()
  File "/usr/bin/puplet", line 191, in _refreshInfo
    if self.updatesObject is not None and \
AttributeError: DBusException instance has no attribute '_dbus_error_name'


Version-Release number of selected component (if applicable):
pirut-1.3.28-13.el5

How reproducible:
Always

Steps to Reproduce:
1. System is registered to RHN
2. run /usr/bin/puplet 
3.
  
Actual results:
Traceback

Expected results:
Successful execution

Additional info:
IIRC puplet is the application which shows a notification icon in GNOME that there are pending updates. Since this used to work in previous releases I'm marking it as regression.

I have additional repos if that matters.
Comment 3 Andrew Gormanly 2009-06-17 06:55:27 EDT
Possible dupe of bug 480339
Comment 4 Alexander Todorov 2009-07-01 06:59:05 EDT
*** Bug 508840 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Todorov 2009-07-01 07:02:19 EDT

*** This bug has been marked as a duplicate of bug 480339 ***

Note You need to log in before you can comment on or make changes to this bug.