This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 50042 - The rpm command fails with error message
The rpm command fails with error message
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 05:12 EDT by Pedritor
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 13:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The install log for my maquine (12.15 KB, text/plain)
2001-07-26 05:13 EDT, Pedritor
no flags Details

  None (edit)
Description Pedritor 2001-07-26 05:12:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
The rpm command fails with error message "cpio: MD5 sum mismatch" randomly.
The packages are good and sometimes are installed ok. Some packages in the
RedHat distribuion CD's (originals) do not install properly due this error.

How reproducible:
Sometimes

Steps to Reproduce:
1.With redhat distribuion (european)
2.rpm -U gcc-2.96-81.i386.rpm
3.
 

Actual Results:  unpacking of archive failed on file <random file>: cpio:
MD5 sum mismatch

Expected Results:  none (install ok)

Additional info:

I the install.log the error apears on some packages, different machines
have different bad packages with the same CD.
Comment 1 Pedritor 2001-07-26 05:13:37 EDT
Created attachment 25047 [details]
The install log for my maquine
Comment 2 Jeff Johnson 2001-07-26 08:53:44 EDT
All package installs and upgrades since rpm-4.0.2 have a MD5sum check
on the file as it is installed, so I have no reason to think that there is an
rpm problem. Try doing an install on another machine to convince
yourself that the problem is not with rpm. What happens if you do that?

Check your machine, random problems can be caused by overclocked
CPU's and/or memory.
Comment 3 Need Real Name 2001-08-14 03:02:42 EDT
I' have the same problems after installing the latest RH7.1 updates.
Rpm fails with most(all) of the packages from other sites and some of the 
packages from the RedHat CD's.
Comment 4 Need Real Name 2001-08-14 03:24:26 EDT
I've done some digging ang broused trough the bug reports.
It looks that there are more complaints about this checsum error.

Bugs : 42470,43291,37940,38528

Maybe somthings broken.
Comment 5 Jeff Johnson 2001-08-14 10:51:46 EDT
I need a reproducible problem in order to fix. Random failures
still smells like either corrupt packages and/or HW to me.

Please reopen this bug if you have a reproducible problem
Comment 6 Need Real Name 2001-08-30 13:16:26 EDT
I've rebooted my system and found some duplicated inode's on my disks. 
Therefore the RPM did work from CD but not from my home directory.

Comment 7 Jeff Johnson 2001-08-30 13:20:37 EDT
OK, WORKSFORME. Thanks for the updated info.
Comment 8 Need Real Name 2001-08-31 05:29:23 EDT
The problem was not copletely resolved. The MD5 error still exists.

This is what I did after the file system was restored. 

I logged in as a normal user.
used ncftp to get the mozilla packadges.
went to runlevel 1. unmount of /home. Did an fsck. no errors where found.
Rebooted the system.
I logged in as a normal user opened a terminal.
used su (without dash) and executed rpm -i mozilla...
This results in an MD5 checsum error for each of the packadges.

After that i've su'ed with dash ( su - ) 
used ncftp to get the mozilla packadges.
rpm -i mozilla...
The checksum error was solved.

any comments?

Note You need to log in before you can comment on or make changes to this bug.