Bug 500438 - can't run fresh installed VM of RHEL5.3 in virt-manager
can't run fresh installed VM of RHEL5.3 in virt-manager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 13:17 EDT by Stefan Assmann
Modified: 2009-05-25 12:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 12:21:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/libvirt/qemu/RHEL5.xml (1.11 KB, text/plain)
2009-05-12 13:17 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2009-05-12 13:17:26 EDT
Created attachment 343632 [details]
/etc/libvirt/qemu/RHEL5.xml

Description of problem:
I started virt-manager and created a new VM. Installed RHEL5.3 from a local iso in the VM. Everything works until the installation is finished and I press the "reboot" button. After that the VM does not boot anymore.
The following error appears:
Error starting domain: internal error Domain RHEL5 didn't show up
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
    self.vm.create()
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 287, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Domain RHEL5 didn't show up

Even after a reboot trying to start the VM won't work and give the above error.
However qemu-kvm /var/lib/libvirt/images/RHEL5.img works fine.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. create a new VM in virt-manager
2. install RHEL5.3 in it (from ISO)
3. reboot the VM
  
Actual results:
virt-manager does not start the VM and returns an error

Expected results:
virt-manager starts the VM

Additional info:
Comment 1 Cole Robinson 2009-05-12 13:25:03 EDT
My guess is this is a dup of bug 499569. Can you check /var/log/libvirt/qemu/<vmname>.log and see if the error matches comment #1 in 499569?
Comment 2 Stefan Assmann 2009-05-13 02:24:06 EDT
There is no /var/log/libvirt/qemu/RHEL5.log. However after looking at bug 499569 I tried to disable selinux and after restarting libvirtd the VM showed up.
Comment 3 Mark McLoughlin 2009-05-25 09:50:46 EDT
Does the guest still fail if you re-enable selinux? If so, please include the output of 'ausearch -m AVC -ts recent"

There should be a log for the guest in /var/log/libvirt/qemu/, also please include that

Finally, what versions of libvirt/python-virtinst/virt-manager/qemu-system-x86 is this?
Comment 4 Stefan Assmann 2009-05-25 10:51:09 EDT
- re-enabled selinux
- restarted libvirtd
- installed RHEL5 in VM
-> works now

Guess this got fixed somewhere along the way :)
Comment 5 Mark McLoughlin 2009-05-25 12:21:36 EDT
Thanks Stefan

Note You need to log in before you can comment on or make changes to this bug.