Bug 500466 - file - /usr/share/magic.mime is needed by package httpd
file - /usr/share/magic.mime is needed by package httpd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 15:49 EDT by Răzvan Sandu
Modified: 2009-10-09 04:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 04:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2009-05-12 15:49:08 EDT
Description of problem:

When trying to upgrade a stock installation (x86_64), we get the following error:

[root@whatever ~]# yum -y --obsoletes upgrade
Loaded plugins: downloadonly, fastestmirror
Loading mirror speeds from cached hostfile
 * epel: ftp.ines.lug.ro
 * base: ftp.gts.lug.ro
 * updates: ftp.gts.lug.ro
 * addons: ftp.gts.lug.ro
 * extras: ftp.gts.lug.ro
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package file.x86_64 0:4.17-15.el5_3.1 set to be updated
--> Processing Dependency: /usr/share/magic.mime for package: httpd
--> Finished Dependency Resolution
httpd-2.2.3-22.el5.centos.x86_64 from installed has depsolving problems
  --> Missing Dependency: /usr/share/magic.mime is needed by package httpd-2.2.3-22.el5.centos.x86_64 (installed)
Error: Missing Dependency: /usr/share/magic.mime is needed by package httpd-2.2.3-22.el5.centos.x86_64 (installed)


Version-Release number of selected component (if applicable):
file-4.17-15
httpd-2.2.3-22.el5.centos


Expected results:
Upgrade should perform normally.
Comment 1 Tomas Mraz 2009-09-25 08:40:19 EDT
It happens with packages from regular RHEL-5 Update 4 (not Centos) as well.
file-4.17-15.el5_3.1
httpd-2.2.3-31.el5
Comment 3 Daniel Novotny 2009-09-25 08:59:58 EDT
hello,
I don't understand the situation, because the file package normally contains
the /usr/share/magic.mime file
Comment 4 Tomas Mraz 2009-09-25 09:22:15 EDT
So the problem is either in rpm or in the repository metadata creation.
Comment 5 Daniel Novotny 2009-09-25 09:31:57 EDT
maybe rpm and/or yum is confused by the fact that it's a symlink...
Comment 6 Dennis Gregorovic 2009-10-08 15:38:05 EDT
I'm not able to reproduce this error.  Which version of yum is being used?  Tomas, which repo are you updating against?
Comment 7 Tomas Mraz 2009-10-09 04:09:19 EDT
It seems that it happened with old rpm and/or yum and RHEL-5.4 repositories. When I updated all the packages to 5.4 with '--exclude file' option given to yum and then updated the file package in the second step it worked.

Note You need to log in before you can comment on or make changes to this bug.