Bug 500470 - Python QPID client is incompatible with python 2.6 (due to SSL)
Python QPID client is incompatible with python 2.6 (due to SSL)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
Development
All All
low Severity medium
: 1.3
: ---
Assigned To: Rafael H. Schloming
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 16:11 EDT by Will Benton
Modified: 2014-12-01 18:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 15:32:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Benton 2009-05-12 16:11:30 EDT
Description of problem:

   The python client is incompatible with the python 2.6 library (as shipped in F11 beta).  

Version-Release number of selected component (if applicable):

   python-qpid-0.5.752600

How reproducible:

   Run qpid-tool or create a Connection object; it will crash (silently, in the case of qpid-tool, since the exception is caught but ignored) in sslwrap because there is no socket.SSLType in Python 2.6.

Steps to Reproduce:
   1.  Run qpid-tool or create a Connection object.
  
Actual results:

   Here's a traceback from qpid-tool:

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/qpid/managementdata.py", line 210, in __init__
    username=self.broker.username, password=self.broker.password)
  File "/usr/lib/python2.6/site-packages/qpid/connection.py", line 66, in __init__
    Assembler.__init__(self, sslwrap(sock))
  File "/usr/lib/python2.6/site-packages/qpid/connection.py", line 58, in sslwrap
    if isinstance(sock, socket.SSLType):

Expected results:

   Testing to see if a socket uses SSL or not should not fail.
Comment 1 Justin Ross 2011-06-28 15:32:44 EDT
This is no longer an issue.

Note You need to log in before you can comment on or make changes to this bug.