Bug 500503 - Hang in radeon_gem_ib_get
Hang in radeon_gem_ib_get
Status: CLOSED DUPLICATE of bug 493068
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 18:46 EDT by Pete Zaitcev
Modified: 2009-05-12 18:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 18:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (w/o the final message from radeon_gem_ib_get) (62.04 KB, text/plain)
2009-05-12 18:46 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2009-05-12 18:46:03 EDT
Created attachment 343670 [details]
dmesg (w/o the final message from radeon_gem_ib_get)

Description of problem:

X hangs. The OS stays up, but needs to be rebooted since X is hard hung.
This occured after a significant uptime, a couple of days.

Version-Release number of selected component (if applicable):

kernel-2.6.29.2-126.fc11.x86_64
xorg-x11-drv-ati-6.12.2-13.fc11.x86_64
xorg-x11-server-Xorg-1.6.1-11.fc11.x86_64

How reproducible:

Unknown, probably not very easy.

Steps to Reproduce:
1. Use the system normally, do not reboot for a couple of days
  
Actual results:

Hang of X

Expected results:

Working normally

Additional info:

Previous xorg-x11-drv-ati was 6.12.2-9, possibly worked ok on same kernel,
but perhaps it's a question of uptime.

Last message:

May 12 16:22:24 niphredil kernel: [drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
May 12 16:22:24 niphredil kernel: [drm:radeon_cs_ioctl] *ERROR* ib_get failed

Stack:

[<ffffffff81042d14>] __cond_resched+0x32/0x5b
[<ffffffffa0021800>] drm_fence_reference_unlocked+0x1e/0x39 [drm]
[<ffffffffa0022adf>] drm_bo_wait+0xf5/0x1c2 [drm]
[<ffffffffa005c220>] radeon_gem_ib_get+0xd4/0x22d [radeon]
[<ffffffffa005fa99>] radeon_cs_ioctl+0x2c2/0x3ad [radeon]
[<ffffffffa0012b6c>] drm_ioctl+0x1fc/0x2b3 [drm]
[<ffffffff810e0e40>] vfs_ioctl+0x6f/0x87
[<ffffffff810e12db>] do_vfs_ioctl+0x462/0x4a3
[<ffffffff810e1372>] sys_ioctl+0x56/0x79
[<ffffffff8101133a>] system_call_fastpath+0x16/0x1b
[<ffffffffffffffff>] 0xffffffffffffffff

The error message appears after a few minutes, so the captured dmesg
does not have it. I'm attaching the actual dmesg without the message
just in case someone wants to see interrupt layout etc.
Comment 1 Pete Zaitcev 2009-05-12 18:54:29 EDT
Oh never mind, it's a dup of bug 493068.

*** This bug has been marked as a duplicate of bug 493068 ***

Note You need to log in before you can comment on or make changes to this bug.