Bug 500513 - notification-demon needs to conflict with xfce4-notifyd
notification-demon needs to conflict with xfce4-notifyd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
rawhide
All Linux
urgent Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 19:53 EDT by Christoph Wickert
Modified: 2013-03-05 22:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 22:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2009-05-12 19:53:45 EDT
Description of problem:
I recently imported xfce4-notifyd, an alternative implemantaion of a notification daemon into F-11 and rawhide. Both conflict since they both provide
/usr/share/dbus-1/services/org.freedesktop.Notifications.service

As both packages also provide the virtual desktop-notification-daemon, yum is getting confused which has caused a number of builds to fail so far, e. g.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1351516

Version-Release number of selected component (if applicable):
notification-daemon-0.4.0-3.fc11

Additional info:
https://fedorahosted.org/rel-eng/ticket/1788
https://www.redhat.com/archives/fedora-devel-list/2009-May/msg01062.html
Comment 1 Toshio Kuratomi 2009-05-12 21:06:25 EDT
This looks like we need both a proper fix and a workaround.  The right fix will be related to this:
  https://bugzilla.redhat.com/show_bug.cgi?id=484945
  https://bugs.freedesktop.org/show_bug.cgi?id=20099

And a temporary workaround until that's implemented.
Comment 2 Christoph Wickert 2009-05-13 22:23:07 EDT
Meanwhile I have patched xfce4-notifyd to no longer conflict with notification-daemon, so this can be closed.

Note You need to log in before you can comment on or make changes to this bug.