Bug 500518 - Condition attributes are ignored when creating pdf files
Condition attributes are ignored when creating pdf files
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Hideo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 23:04 EDT by David O'Brien
Modified: 2010-11-23 23:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 23:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2009-05-12 23:04:33 EDT
Description of problem:

When creating pdf files, publican does not respect the use of condition attributes (e.g., <para condition="fedora">) to specify that only certain parts of a document be built.

When used to create html output, the results are as expected.

Version-Release number of selected component (if applicable):

0.45

How reproducible:

Always

Steps to Reproduce:
1. Create a para or other suitable tag, and include a condition attribute.
2. Create a second para, and use a different condition
3. Build the book specifying a single condition

  
Actual results:

Paragraphs of both conditions are displayed.

Expected results:

Only the paragraph of the specified condition should display.

Additional info:
Comment 1 David O'Brien 2009-05-13 00:20:08 EDT
ok, this is not a pdf problem, it's a function of where the condition exists.

The condition I was using was in the Feedback.xml file, part of /Common_Content, and this does not respect conditions in either html or pdf.

If I create a local Feedback.xml then the conditions are respected in both html and pdf.

So, still a problem, but not a critical problem. It just means creating a local Feedback.xml file for every book.
Comment 2 David O'Brien 2009-05-13 23:32:12 EDT
A bit more education and it turns out this is not an issue.

Note You need to log in before you can comment on or make changes to this bug.