Bug 500533 - Anaconda fails to find root on preupgrade
Anaconda fails to find root on preupgrade
Status: CLOSED DUPLICATE of bug 499321
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 03:06 EDT by Sven Lankes
Modified: 2009-05-13 09:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 09:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace saved by anaconda (96.60 KB, text/plain)
2009-05-13 03:06 EDT, Sven Lankes
no flags Details
Anaconda backtrace with only one disk (76.28 KB, text/plain)
2009-05-13 03:42 EDT, Sven Lankes
no flags Details
/tmp/storage.log (7.93 KB, text/plain)
2009-05-13 09:07 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Sven Lankes 2009-05-13 03:06:23 EDT
Created attachment 343715 [details]
Backtrace saved by anaconda

Description of problem:
 
I tried to update my f10 install to rawhide using preupgrade-1.1.0-0.pre3. 
Anaconda failed to find the root of my installation and offered to do a fresh install instead.

Version-Release number of selected component (if applicable):

Anaconda from rawhide as of "2009-05-12".

Actual results:

No update to rawhide

Expected results:

update to rawhide

Additional info:

This machine has two harddrives - sda is the current drive and sdb is an old drive that also still has a fedora install on it.
Comment 1 Sven Lankes 2009-05-13 03:42:47 EDT
Created attachment 343716 [details]
Anaconda backtrace with only one disk

I have now physically disconnected the 2nd drive and anaconda still fails to find the root and start the update.
Comment 2 Michal Schmidt 2009-05-13 08:55:55 EDT
I am seeing the same problem. In my case I tried to use preupgrade to upgrade a F9 Xen VM to current Rawhide.

What we both seem to have in common is that we have the root fs on LVM and in the log from Anaconda there is no indication that it even tried to detect the filesystems on the LVs.
Comment 3 Michal Schmidt 2009-05-13 09:07:37 EDT
Created attachment 343761 [details]
/tmp/storage.log

This is my /tmp/storage.log from Anaconda. As you can see, /dev/xvda1 (my /boot partition) was correctly detected as ext3, and /dev/xvda2 was correctly detected as an LVM physical volume, but the filesystems on the logical volumes are not detected.
Comment 4 Chris Lumens 2009-05-13 09:14:03 EDT

*** This bug has been marked as a duplicate of bug 499321 ***

Note You need to log in before you can comment on or make changes to this bug.