Bug 50056 - Reiserfs don't umount
Reiserfs don't umount
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-07-26 07:56 EDT by ferulisses
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-10 14:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description ferulisses 2001-07-26 07:56:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)

Description of problem:
Making upgrade to 2.4.3-12 kernel, if I have a reiserfs partition, I
can't umount it.

How reproducible:

Steps to Reproduce:
1. Upgrade do Kernel 2.4.3-12 from RedHat Errata, boot it.
2. If you wanna, upgrade to mount-2.11b-3 too, no matters.
3. Format a partition with reiserfs (mkreiserfs /dev/XXXX)
4. Mount the partition.
5. Try Umount the partition.

Actual Results:  umount never return, don't umount.

Expected Results:  umount the partition.

Additional info:

It may cause loss of data on computer shutdown, when umount can't
umount the reiserfs, and keep other open, the only way is pressing
Reset button.
Comment 1 Arjan van de Ven 2001-07-30 12:10:38 EDT
Could you try the 2.4.3-15 kernel I put on
http://people.redhat.com/arjanv/testkernels  ?
That should have a fix for this.
Comment 2 john.l.villalovos 2001-08-02 12:10:41 EDT
This bug is the same as 45628.  Should close this and mark as duplicate of 45628.
Comment 3 John Dalbec 2001-08-17 08:05:16 EDT
I tried kernel 2.4.3-15.  It worked for me.  Does this kernel include the ReiserFS/NFS compatibility patch for knfsd?
Comment 4 Arjan van de Ven 2001-08-17 08:09:06 EDT
no, that patch wasn't ready for mainstream in the 2.4.3 timeframe.
Comment 5 John Dalbec 2001-08-22 15:08:00 EDT
In 2.4.3-15, did you just enable CONFIG_REISERFS_CHECK instead of applying a
patch for umount?  Is this going to cause a big performance hit?
Comment 6 Arjan van de Ven 2001-08-22 16:37:38 EDT
I didn't touch that setting in -15; just fixed the real bug.
There now is a -16 up (same place) with a fix for the dmfe NIC driver; if/when I
make a -17 I can disable this check; however Chris Mason (SuSE, major reiserfs
contributor) doesn't think it makes a lot of performance difference, except in
strange benchmark cornercases.

Note You need to log in before you can comment on or make changes to this bug.