Bug 500594 - gnu-efi-debuginfo is empty
gnu-efi-debuginfo is empty
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnu-efi (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 08:02 EDT by Alexander Todorov
Modified: 2013-04-12 16:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 10:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-05-13 08:02:39 EDT
Description of problem:
gnu-efi-debuginfo is empty.

Version-Release number of selected component (if applicable):
gnu-efi-debuginfo-3.0c-1.1.i386.rpm

How reproducible:
always

Steps to Reproduce:
1. rpm -qpl gnu-efi-debuginfo-3.0c-1.1.i386.rpm
2.
3.
  
Actual results:
empty package

Expected results:
not quite sure. see additional info.

Additional info:
gnu-efi contains several .a files and one ELF file which is not stripped.
$ file /usr/lib/gnuefi/crt0-efi-ia32.o
/usr/lib/gnuefi/crt0-efi-ia32.o: ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped

Either the debuginfo package should contain some useful information or it should not be present if not used.
Comment 3 Chris Lumens 2009-05-13 10:25:46 EDT
The debuginfo package here is useless too since you'd never be able to debug in
the environment gnu-efi runs in.  I've made sure the next build of this package
in Fedora will not have the debuginfo package, which means I'm going to close
this as NEXTRELEASE too.

Note You need to log in before you can comment on or make changes to this bug.