Bug 500607 - ValueError: filedescriptor out of range in select()
ValueError: filedescriptor out of range in select()
Status: CLOSED DUPLICATE of bug 499854
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 08:39 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 09:16:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-05-13 08:39:45 EDT
Description of problem:

Installing RHTS test system dell-pe1850-01.rhts.bos.redhat.com with rawhide-20090512 results in traceback

Version-Release number of selected component (if applicable):

 * anaconda-11.5.0.51

How reproducible:


Steps to Reproduce:
1. Provision RHTS test system with rawhide
  
Actual results:


Install fails due to what appears to be %post processing.  For a full log, see http://rhts.redhat.com/testlogs/58387/195456/1627708/console.txt.  Note traceback below

anaconda 11.5.0.51 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/subprocess.py", line 1166, in _communicate
    rlist, wlist, xlist = select.select(read_set, write_set, [])
  File "/usr/lib64/python2.6/subprocess.py", line 671, in communicate
    return self._communicate(input)
  File "/usr/lib/anaconda/iutil.py", line 96, in execWithRedirect
    (outStr, errStr) = proc.communicate()
  File "/usr/lib/anaconda/kickstart.py", line 84, in run
    root = scriptRoot)
  File "/usr/lib/anaconda/kickstart.py", line 1205, in <lambda>
    map (lambda s: s.run(anaconda.rootPath, flags.serial, anaconda.intf), postScripts)
  File "/usr/lib/anaconda/kickstart.py", line 1205, in runPostScripts
    map (lambda s: s.run(anaconda.rootPath, flags.serial, anaconda.intf), postScripts)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/cmdline.py", line 148, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 966, in <module>
    anaconda.intf.run(anaconda)
ValueError: filedescriptor out of range in select()

install exited abnormally [1/1] 



Expected results:

No traceback


Additional info:

 * ks.cfg - http://rhts.redhat.com/testlogs/58387/195456/1627708/ks.cfg
 * program.log - http://rhts.redhat.com/testlogs/58387/195456/1627708/program.log
 * storage.log - http://rhts.redhat.com/testlogs/58387/195456/1627708/storage.log
 * Additional log files - http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=8109033
Comment 1 Chris Lumens 2009-05-13 09:16:23 EDT

*** This bug has been marked as a duplicate of bug 499854 ***

Note You need to log in before you can comment on or make changes to this bug.