Bug 50064 - If "switchdesk kde" is run before starting X for the first time, sawfish does not become part of the default GNOME settings
If "switchdesk kde" is run before starting X for the first time, sawfish does...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 09:29 EDT by Panic
Modified: 2013-04-02 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 17:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-07-26 09:29:33 EDT
Description of Problem:

Okay, this is bizarre, I agree.  It's a low-probability path as well, which
is why I marked it low priority.  I attached this to sawfish becuase I
didn't know where else to put it.  Here goes:

You install beta3, choose GNOME as your default but with a text login. 
Upon logging in as root and before starting X, you change your mind and run
"switchdesk kde".  Switchdesk tells you to delete .Xclients to restore the
defaults.  KDE runs fine at this point.

However, if you delete the .Xclients file and try to go back to GNOME,
sawfish refuses to start when GNOME comes up.  In addition, this applies to
*all users* who haven't run GNOME before (apparently).  You can start
sawfish from the command line inside of GNOME, and all is good -- but it
won't start during initialization.

Running "switchdesk gnome" fixes the problem for everyone across the board,
and after running GNOME once like this, I cannot recreate the problem.

How Reproducible:

Once -- I'll have to reinstall to verify the sequence of events.

Steps to Reproduce:
1. Install, choose GNOME default, text login
2. log in as root, run "switchdesk kde", run KDE
3. delete /root/.Xclients and .Xclients-default, and then try to run GNOME.
 Note the lack of a window manager.

Actual Results:

Sawfish did not start.

Expected Results:

Sawfish should have started by default the first time GNOME was run (after
removing .Xclients to re-establish the default settings).

Additional Information:

It looks like if you leave the settings at GNOME and start GNOME,all is
well -- it is only this strange path that shows the problem.  Some setting
about default window manager that GNOME looks for and won't set if it is
already there?
Comment 1 Glen Foster 2001-07-30 14:35:47 EDT
If you can reproduce this, we'll mark it SHOULD-FIX; let me know.
Comment 2 Panic 2001-07-30 17:51:30 EDT
uh-oh -- it's worse than I thought.  On a roswell-i386 installation, booting to
runlevel 3 and running startx results in a missing window manager and a series
of error windows.  Definitely reproduceable, but only on the *first* startup --
the second startup works fine. <sigh>  I'll run another installation overnight
to make sure.  Errors were:

******
Application "panel" (process 11739) has crashed due to a fatal error.
(Segmentation Fault).
******

Two instances of (after starting sawfish):

******
I've detected a panel already running.  Start another panel as well? Y/N
******

Added to that I have the Nautilus "you are running as root" error, a DeskGuide
"no Gnome-compliant window manager" error, and I've got two battery applets on
my task bar. :)

Proceeding after starting sawfish manually, the tasklist-applet and the
deskguide-applet both crash.  In the sawfish terminal window, I go this error:

*****
Error: max-lisp-depth exceeded, possible infinite recursion?
*****

I removed the second battery applet from the taskbar, the deskguide and tasklist
applets seem to be running normally now, and everything is okay, and restarting
X/Gnome now works fine for all users.  From this experience, I would say it is
something wrong with the first GNOME startup, regardless of whether or not
switchdesk is used.  Again, I'll do an install overnight tonight and test again.
Comment 3 Panic 2001-07-30 17:55:41 EDT
update -- the panel and applet errors seem to be related to starting Nautilus as
root -- I'm still getting those, so they are separate from the missing window
manager problem.
Comment 4 Panic 2001-07-31 14:23:40 EDT
This is now confirmed -- booting to runlevel 3 and running startx starts GNOME
without sawfish, and gives the multiple panel starting problems being seen
elsewhere as well.
Comment 5 Havoc Pennington 2002-03-04 16:04:18 EST
Multi-panel thing was fixed prior to 7.2 AFAIK.

I haven't gotten other reports of the switchdesk losing sawfish, that I remember.

Have you seen this in 7.2 final?

Note You need to log in before you can comment on or make changes to this bug.