Bug 500711 - The kdump initrd file is rebuilt on every reboot.
The kdump initrd file is rebuilt on every reboot.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 15:15 EDT by Robert N. Evans
Modified: 2009-05-13 16:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 16:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert N. Evans 2009-05-13 15:15:19 EDT
Description of problem:
There is a delay estimated to be 30-seconds every time the system reboots when the initramfs used for kdump gets needlessly rebuilt.

Version-Release number of selected component (if applicable):
kexec-tools-1.102pre-56.el5

How reproducible:
happens every time if pre-condition is present

Steps to Reproduce:
1. add an "extra-module" to the kdump config file
2. reboot the system
3. watch the initramfs get rebuild when services are started
  
Actual results:
initramfs gets rebuild on every reboot

Expected results:
initramfs gets rebuild once, but not on future reboots (since the required initramfs content has not changed.)


Additional info:
This is a regression from the way this worked in RHEL5.2.

According to https://bugzilla.redhat.com/show_bug.cgi?id=459614#c6 this behaviour was intentionally introduced.
Comment 1 Neil Horman 2009-05-13 16:51:21 EDT
yes, it was introduced on request from richard johnson at stratus.  If an extra module is specified, it can't be conclusively proven to not have have been updated if that module isn't in the kernel tree from the last build, so we universally force a rebuild if extra_modules are being added to be safe

Note You need to log in before you can comment on or make changes to this bug.