Bug 500718 - Anaconda traceback from rhts installation attempt - failure in creating logical volume
Anaconda traceback from rhts installation attempt - failure in creating logic...
Status: CLOSED DUPLICATE of bug 495247
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 15:42 EDT by Mike Gahagan
Modified: 2009-06-09 11:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 11:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2009-05-13 15:42:09 EDT
Description of problem:
[m                                                                               Running anaconda 11.5.0.51, the Fedora system installer - please wait...
Running pre-install scripts
Finding storage devices...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 933, in <module>
    kickstart.fullCommandPass(anaconda, opts.ksfile, earlyKS)
  File "/usr/lib/anaconda/kickstart.py", line 1169, in fullCommandPass
    ksparser.readKickstart(file)
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 759, in readKickstart
    self._stateMachine (lambda: fh.readline())
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 634, in _stateMachine
    self.handleCommand(lineno, args)
  File "/usr/lib/anaconda/kickstart.py", line 1094, in handleCommand
    KickstartParser.handleCommand(self, lineno, args)
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 467, in handleCommand
    self.handler.dispatcher(args, lineno, self._preceededInclude)
  File "/usr/lib/python2.6/site-packages/pykickstart/base.py", line 376, in dispatcher
    obj = self.commands[cmd].parse(args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 433, in parse
    percent=lvd.percent)
  File "/usr/lib/anaconda/storage/__init__.py", line 644, in newLV
    return LVMLogicalVolumeDevice(name, vg, *args, **kwargs)
  File "/usr/lib/anaconda/storage/devices.py", line 1933, in __init__
    self.vg._addLogVol(self)
  File "/usr/lib/anaconda/storage/devices.py", line 1753, in _addLogVol
    raise DeviceError("new lv is too large to fit in free space", self.path)
storage.errors.DeviceError: ('new lv is too large to fit in free space', '/dev/mapper/VolGroup00')
install exited abnormally [1/1] 
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0 LOOP_CLR_FD failed: 16
	/proc done
	/dev/pts done
	/sys done
	/mnt/stage2 done
	/selinux done
nm-dispatcher.action: Caught signal 15, shutting down...
sending termination signals...done
sending kill signals...done
you may safely reboot your system


Version-Release number of selected component (if applicable):
rawhide-20090512

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=8107767
console: http://rhts.redhat.com/testlogs/58338/195267/1626869/console.txt

unfortunately no other logs were present in rhts.
Comment 1 Mike Gahagan 2009-05-13 15:52:30 EDT
This might be related to (maybe a dup of) bz 495247
Comment 2 Andy Lindeberg 2009-06-09 11:44:32 EDT

*** This bug has been marked as a duplicate of bug 495247 ***
Comment 3 Bug Zapper 2009-06-09 11:46:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.