Bug 500720 - kickstart partitioning
kickstart partitioning
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 16:00 EDT by Steve Berg
Modified: 2009-05-13 16:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 16:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Partitioning excerpt of kickstart file (1.60 KB, text/plain)
2009-05-13 16:00 EDT, Steve Berg
no flags Details

  None (edit)
Description Steve Berg 2009-05-13 16:00:05 EDT
Created attachment 343865 [details]
Partitioning excerpt of kickstart file

Description of problem:
When using --start and --end to define the cylinders a partition should use on a harddrive anaconda fails with a message that --size is needed.


Version-Release number of selected component (if applicable):


How reproducible: 
Every time when a kickstart file contains part statements and they use the --start and --end flags.


Steps to Reproduce:
1.  Create a kickstart, include part statements using the --start and --end flags.
2.  Do a network install pointing to the kickstart.
  
Actual results:
The install fails.

Expected results:
Harddrives should be partitioned according the kickstart file and installation should continue in an automated fashion. 

Additional info:
Comment 1 Chris Lumens 2009-05-13 16:14:08 EDT
The --start= and --end= parameters no longer do anything.  The build of pykickstart that'll show up in F11 enforces this by printing a deprecation warning.  The reason it's asking you for size information is that it's got nothing to go on for how the partition should be laid out.

Note You need to log in before you can comment on or make changes to this bug.