Bug 500751 - gnome-terminal does not display in bold with Terminus as font
gnome-terminal does not display in bold with Terminus as font
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: terminus-font (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 18:37 EDT by Ian Weller
Modified: 2009-06-26 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 13:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of bold not working (6.43 KB, image/png)
2009-05-13 19:43 EDT, Ian Weller
no flags Details

  None (edit)
Description Ian Weller 2009-05-13 18:37:32 EDT
Description of problem:
even with the "Allow bold" checkbox checked for the profile, when using the Terminus font for gnome-terminal, it will not display bold.

Version-Release number of selected component (if applicable):
gnome-terminal-2.26.1-1.fc11.x86_64
terminus-fonts-4.28-8.fc11.noarch

How reproducible:
every time


not sure if this is a gnome-terminal issue or terminus-fonts issue so I'm putting it here since it used to work before just fine.
Comment 1 Behdad Esfahbod 2009-05-13 18:46:19 EDT
Hi.  Can you file this upstream against "vte" please:
bugzilla.gnome.org
Comment 2 Behdad Esfahbod 2009-05-13 19:25:53 EDT
Works beautifully for me.  What version of vte?
Can you attach screenshot of the output of:

$ echo test; tput bold; echo test

Does it help if you open Profile Preferences and choose "Terminus" explicitly?  Also, which font size triggers it?
Comment 3 Ian Weller 2009-05-13 19:43:09 EDT
Created attachment 343891 [details]
screenshot of bold not working

(In reply to comment #2)
> Works beautifully for me.  What version of vte?
vte-0.20.1-1.fc11.x86_64

> Can you attach screenshot of the output of:
> 
> $ echo test; tput bold; echo test
> 
Attached.

> Does it help if you open Profile Preferences and choose "Terminus" explicitly? 
> Also, which font size triggers it?  
That doesn't help. The font size is either 9pt or 10pt (both look the same)

Do I still need to file upstream?
Comment 4 Behdad Esfahbod 2009-05-13 20:00:32 EDT
terminus at 8px has the same glyphs for Medium and Bold.  -> font bug
But srsly, at that size what do you want them to do?

Now, IF that bold font is removed, vte will use freetype's emboldening I guess.

In previous releases (F10 and older I guess) we were always using emboldening and never tried to use the bold typeface.  So it "worked" before.  But I'm not sure emboldened 8px font is any readable.

Anyway, it's out of my jurisdiction.  Reassigning to terminus.
Comment 5 Ian Weller 2009-05-13 22:02:33 EDT
thanks for clearing up which package has the problem.

the emboldened version at the font sizes i mentioned looked just fine, was still quite readable.
Comment 6 Bug Zapper 2009-06-09 11:47:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Ian Weller 2009-06-26 13:52:22 EDT
Closing own bug as not a bug, I assume you agree :)

Note You need to log in before you can comment on or make changes to this bug.