Bug 500760 - [zh_CN] Translation of Note isn't clear and has weird white space
[zh_CN] Translation of Note isn't clear and has weird white space
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 22:51 EDT by Liam Li
Modified: 2009-10-08 08:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-08 08:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for im-chooser (18.00 KB, image/png)
2009-05-13 22:51 EDT, Liam Li
no flags Details

  None (edit)
Description Liam Li 2009-05-13 22:51:26 EDT
Created attachment 343902 [details]
Screenshot for im-chooser

Description of problem:
In"Enable input method" checkbox,some words are not clear, have some  empty string in the sentence

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Choose System->Preferences->Input Method (or run im-chooser) 
2. "Enable input method" checkbox pops up
3. check the UI ,see more from attached image.
  
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2009-05-14 05:54:21 EDT
That need any feedbacks from a translator or any suggestions with po are welcome.
Comment 2 Peng Huang 2009-05-14 22:36:57 EDT
I did not find any problem. 
Liam Li, Please upload a screenshot for the problem. Thanks.
Comment 3 Akira TAGOH 2009-05-15 00:52:23 EDT
BTW that notes are displayed differently if you run it on different environments, if the translation is wrong, that would be better checking others as well.

Here is testcases:

1. LANG=zh_CN.UTF-8 XMODIFIERS=@im=imsettings GTK_IM_MODULE= QT_IM_MODULE=blahblahblah im-chooser
2. LANG=zh_CN.UTF-8 XMODIFIERS=@im=imsettings GTK_IM_MODULE=blahblahblah QT_IM_MODULE= im-chooser
3. LANG=zh_CN.UTF-8 XMODIFIERS=@im=imsettings GTK_IM_MODULE=blahblahblah QT_IM_MODULE=blahblahblah im-chooser
4. LANG=zh_CN.UTF-8 XMODIFIERS=@im=blahblahblah GTK_IM_MODULE= QT_IM_MODULE= im-chooser
5. LANG=zh_CN.UTF-8 XMODIFIERS=@im=blahblahblah GTK_IM_MODULE=blahblahblah QT_IM_MODULE= im-chooser
6. LANG=zh_CN.UTF-8 XMODIFIERS=@im=blahblahblah GTK_IM_MODULE= QT_IM_MODULE=blahblahblah im-chooser
7. LANG=zh_CN.UTF-8 XMODIFIERS=@im=blahblahblah GTK_IM_MODULE=blahblahblah QT_IM_MODULE=blahblahblah im-chooser
Comment 4 Noriko Mizumoto 2009-05-15 01:01:34 EDT
zh_CN translator is added in cc.
Comment 5 Peng Huang 2009-05-15 01:20:43 EDT
msgid ""
"<small><i>Note: this change will not take effect until you next log in%s</"
"i></small>"
msgstr "<small><i>请注意:这个修改在您下一次登录 %s 时才会生效</i></small>"

Hi Tagoh-san, I found there two spaces before and after "%s". Maybe we could remove them.
Comment 6 Wei Liu 2009-05-15 02:51:20 EDT
In zh-CN.po,two spaces before and after "%s" has been removed and "请注意" has been modified to "注". However, it still doesnot make sense to me compares with the screen shot. What does "%s" refer to here? In the screen shot, there is a string "除 GTK+ 应用程序", but not exist either in en-US.po or zh-CN.po.
Comment 7 Akira TAGOH 2009-05-15 04:46:57 EDT
(In reply to comment #6)
> In zh-CN.po,two spaces before and after "%s" has been removed and "请注意" has
> been modified to "注". However, it still doesnot make sense to me compares with
> the screen shot. What does "%s" refer to here? In the screen shot, there is a
> string "除 GTK+ 应用程序", but not exist either in en-US.po or zh-CN.po.  

I don't know how it looks like on your client application to update the translation but if you look into zh_CN.po directly and find out "Note" thing, you'll see helpful examples to translate them how it looks like on this application. plus, to reduce having a lot of messages, it combines various messages to build up the real string. i.e. for the above case:

msgid "GTK+ applications"
msgstr "GTK+ 应用程序"

msgid ", except %s"
msgstr ", 除 %s 之外"

Hope that helps.
Comment 8 Bug Zapper 2009-06-09 11:48:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Akira TAGOH 2009-07-23 22:01:50 EDT
Any updates on this?
Comment 10 Akira TAGOH 2009-09-15 22:46:48 EDT
im-chooser 1.2.7-1.fc12 has been built. please check the translation if it's comfortable.
Comment 11 Akira TAGOH 2009-10-08 08:25:33 EDT
If there are still any issues, please reopen this.

Note You need to log in before you can comment on or make changes to this bug.