Bug 500770 - AttributeError: 'NoneType' object has no attribute 'number' in 11.5.0.51-1.fc11
AttributeError: 'NoneType' object has no attribute 'number' in 11.5.0.51-1.fc11
Status: CLOSED DUPLICATE of bug 500932
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 02:09 EDT by Luke Macken
Modified: 2016-09-19 22:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 14:30:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full traceback (284.61 KB, text/plain)
2009-05-14 02:09 EDT, Luke Macken
no flags Details

  None (edit)
Description Luke Macken 2009-05-14 02:09:36 EDT
Created attachment 343912 [details]
Full traceback

Description of problem:

I triggered this traceback when doing some custom partitioning on an eeepc 900.

anaconda 11.5.0.51-1.fc11 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 616, in cmpActions
    ret = cmp(a1.device.partedPartition.number,
  File "/usr/lib/anaconda/storage/devicetree.py", line 659, in processActions
    self._actions.sort(cmp=cmpActions)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
AttributeError: 'NoneType' object has no attribute 'number'
Comment 1 James Laska 2009-05-15 13:18:11 EDT
Looks to be the same as bug#500932
Comment 2 Chris Lumens 2009-05-15 14:30:09 EDT

*** This bug has been marked as a duplicate of bug 500932 ***

Note You need to log in before you can comment on or make changes to this bug.