Bug 500797 - ``file'' is not an optional argument in `ecryptfs-rewrap-passphrase command', but ``-'' is
``file'' is not an optional argument in `ecryptfs-rewrap-passphrase command',...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ecryptfs-utils (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Michal Hlavinka
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 05:28 EDT by Michal Nowak
Modified: 2013-03-07 21:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 10:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-05-14 05:28:50 EDT
Description of problem:

"""
SYNOPSIS
       ecryptfs-rewrap-passphrase [file]

       printf "%s\n%s"  "old  wrapping  passphrase"  "new  wrapping  passphrase"  |  ecryptfs-rewrap-
       passphrase [file] -
"""

The description is wrong, because the ``file'' is necessary to be present in the command line, otherwise:

May 14 05:01:55 hp-ml370g4-01 ecryptfs-insert-wrapped-passphrase-into-keyring: Error attempting to open [-] for reading 

Version-Release number of selected component (if applicable):

ecryptfs-utils-75-1.el5

Expected results:

Remove '[' and ']' around ``file'', add them to ``-''.

It's probably the same for all ecryptfs-*wrap* man pages.
Comment 1 Michal Hlavinka 2009-05-18 10:22:39 EDT
I don't know about any standard reflecting [] usable only for optional arguments and without this I can hardly convince upstream that this change is worthwhile.

note: there are other man pages using [] for non-optional arguments (for example man tee).
Comment 2 Michal Nowak 2009-05-18 10:32:22 EDT
Nor do I. Closing, since we don't have an authoritative source.

Note You need to log in before you can comment on or make changes to this bug.