Bug 500848 - SIGSEGV in anaconda stage 1
SIGSEGV in anaconda stage 1
Status: CLOSED DUPLICATE of bug 500775
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
s390x Linux
high Severity high
: beta
: ---
Assigned To: David Cantrell
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 10:19 EDT by Jan Stodola
Modified: 2009-06-05 10:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 10:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2009-05-14 10:19:03 EDT
Description of problem:
Anaconda receives SIGSEGV in stage 1

Version-Release number of selected component (if applicable):
RHEL5.4-Server-20090514.nightly

How reproducible:
always

Steps to Reproduce:
1. run rhts test with RHEL5.4-Server-20090514.nightly tree on s390x

  
Actual results:

07:45:05 INFO    : loaded dasd_diag_mod from /modules/modules.cgz
07:45:05 INFO    : loaded dasd_fba_mod from /modules/modules.cgz
07:45:05 INFO    : loaded dasd_eckd_mod from /modules/modules.cgz
07:45:05 INFO    : inserted /tmp/dasd_diag_mod.ko
07:45:05 INFO    : inserted /tmp/dasd_fba_mod.ko
20004000000-2000402b000 rw-p 20004000000 00:00 0
2000402b000-20008000000 ---p 2000402b000 00:00 0
3ffff9df000-3ffff9f4000 rw-p 3fffffeb000 00:00 0                         stack

loader received SIGSEGV!  Backtrace:
0x800007d0
0x3ffff9f169c
0x80195a92
0x8011e1cc
0x8012e058
0x80135b92
0x8013a75c
0x8005ed6a
0x8005f446
0x800567c0
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
 /proc done
 /dev/pts done
 /sys done
 /tmp/ramfs done
you may safely reboot your system


Expected results:
anaconda doesn't crash

Additional info:
Job in RHTS:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=58631
Comment 1 Chris Lumens 2009-05-14 10:40:32 EDT
Hans was taking a look at this one.
Comment 2 Hans de Goede 2009-05-14 13:32:34 EDT
(In reply to comment #1)
> Hans was taking a look at this one.  

I'm taking a look at bug 500775, this might very well be the same, but I'm not sure, so this will need to be retested once bug 500775 is resolved.
Comment 4 Brock Organ 2009-05-19 11:11:44 EDT
this appears to me to be the same issue as bug 500775, because of a reverting of some patches, the current test tree (RHEL5.4-Server-20090519.nightly does not have the error ...

I would like to propose that we resolve this bug (since the current internal trees are installable), but leave bug 500775 open to track the still open issue with respect to the reverted patches getting fixed ...

Brock
Comment 5 Denise Dumas 2009-06-05 10:48:33 EDT

*** This bug has been marked as a duplicate of bug 500775 ***

Note You need to log in before you can comment on or make changes to this bug.