Bug 50085 - xinetd doesn't work with datagram sockets
Summary: xinetd doesn't work with datagram sockets
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tftp (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-26 17:32 UTC by Ahmon Dancy
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 18:14:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ahmon Dancy 2001-07-26 17:32:22 UTC
Description of Problem:

I'm trying to set up a tftp server on Redhat 7.1.  I have the tftpd package installed.  

My /etc/xinetd.d/tftp is as follows:

# default: off
# description: The tftp server serves files using the trivial file transfer \
#	protocol.  The tftp protocol is often used to boot diskless \
#	workstations, download configuration files to network-aware printers, \
#	and to start the installation process for some operating systems.
service tftp
{
	disable	= no
	socket_type		= dgram
	wait			= yes
	user			= nobody
	log_on_success		+= USERID
	log_on_failure 		+= USERID
	server			= /usr/sbin/in.tftpd
	server_args		= /tftpboot
}

However, when I start, restart, or reload xinetd I get the message:
 xinetd[506]: socket creation failed (Socket type not supported (errno = 94)). service = tftp
(in /var/log/messages)


If I do an strace on xinetd I see

socket(PF_INET, SOCK_DGRAM, IPPROTO_TCP) = -1 ESOCKTNOSUPPORT (Socket type not supported)

SOCK_DGRAM and IPPROTO_TCP definitely do not go together.

It looks like in the sources...  the third parameter to socket() is always zero.  That's probably the problem.

Comment 1 Ahmon Dancy 2001-07-26 18:14:14 UTC
adding 'protocol=udp' to /etc/xinetd.d/tftp made the problem go away but it would be nice if xinetd chose a reasonable default protocol when one isn't specified.

Comment 2 Trond Eivind Glomsrxd 2001-07-26 18:19:57 UTC
tftp-server-0.17-14 (and probably earlier ones, but that's one I verified) have
protocol=udp in its xinetd.


Note You need to log in before you can comment on or make changes to this bug.