Bug 50086 - Anaconda fails to format 16 SCSI drives or more
Anaconda fails to format 16 SCSI drives or more
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 13:34 EDT by pvial
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 12:54:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pvial 2001-07-26 13:34:22 EDT
Description of Problem:
This traceback occured when the installer attempted to format the 16 SCSI 
drives in my machine.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1469, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 577, in 
makeFilesystems
    for label in self.readLabels(labelSkipList).values():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 532, in 
readLabels
    label = isys.readExt2Label(dev)
  File "/usr/lib/anaconda/isys.py", line 312, in readExt2Label
    makeDevInode(device, "/tmp/disk")
  File "/usr/lib/anaconda/isys.py", line 195, in makeDevInode
    return _isys.mkdevinode(name, fn)
SystemError: (6, 'Device not configured')

Local variables in innermost frame:
fn: /tmp/disk
name: sdp16

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6


How Reproducible:
I have a system with a QLogic 2200 (w/4 drives), a Adaptec 2940U2W (w/2 
drives), a Symbios 22801 (w/4 drives), and a Adaptec 7899 based controller 
(w/5 drives on chan A and 3 on chan B).  I am installing to the Adaptec 
7899 chan A, SCSI ID 0.  All other drives have one partition only even 
though in the traceback it references sdp16.  I am attempting to give 
mount points to all the partitions and format them in the installer.  This 
fails immediately when anaconda tries to format them.  The partitioning of 
the disks is always successful.

Comment:
Is this a limitation of anaconda in 7.0?  I can use RH 7.1 and it installs 
fine, however, my customers want to use 7.0.
Comment 1 pvial 2001-07-26 13:36:39 EDT
Reference bugzilla bug #31978
This bug has the exact same traceback as my bug and he uses a QLogic 2200.  
Coincidence?
Comment 2 Michael Fulbright 2001-07-27 15:59:20 EDT
You are limited to 15 partitions per SCSI drive.  You were trying to create
a 16th partition on sdp is what it looks like from the traceback.

Is this the case?

Comment 3 pvial 2001-07-30 12:54:13 EDT
I am creating one partition per drive on 16 drives.  sdp16 should actually read 
sdp1 since I only had one partition on that drive.  Read my older comments for 
more detail.  I attempted installation on 17 and 18 drives and I got the same 
exact traceback.
Comment 4 Brent Fox 2001-08-13 18:55:10 EDT
I think this may be a limitation of the 2.2 kernel.  If you look at the
/dev/directory on a 2.2 based system, you see this:

sda    sdb2   sdd    sde2   sdg    sdh2   sdj    sdk2   sdm    sdn2   sdp
sda1   sdb3   sdd1   sde3   sdg1   sdh3   sdj1   sdk3   sdm1   sdn3   sdp1
sda10  sdb4   sdd10  sde4   sdg10  sdh4   sdj10  sdk4   sdm10  sdn4   sdp10
sda11  sdb5   sdd11  sde5   sdg11  sdh5   sdj11  sdk5   sdm11  sdn5   sdp11
sda12  sdb6   sdd12  sde6   sdg12  sdh6   sdj12  sdk6   sdm12  sdn6   sdp12
sda13  sdb7   sdd13  sde7   sdg13  sdh7   sdj13  sdk7   sdm13  sdn7   sdp13
sda14  sdb8   sdd14  sde8   sdg14  sdh8   sdj14  sdk8   sdm14  sdn8   sdp14
sda15  sdb9   sdd15  sde9   sdg15  sdh9   sdj15  sdk9   sdm15  sdn9   sdp15
sda2   sdc    sdd2   sdf    sdg2   sdi    sdj2   sdl    sdm2   sdo    sdp2
sda3   sdc1   sdd3   sdf1   sdg3   sdi1   sdj3   sdl1   sdm3   sdo1   sdp3
sda4   sdc10  sdd4   sdf10  sdg4   sdi10  sdj4   sdl10  sdm4   sdo10  sdp4
sda5   sdc11  sdd5   sdf11  sdg5   sdi11  sdj5   sdl11  sdm5   sdo11  sdp5
sda6   sdc12  sdd6   sdf12  sdg6   sdi12  sdj6   sdl12  sdm6   sdo12  sdp6
sda7   sdc13  sdd7   sdf13  sdg7   sdi13  sdj7   sdl13  sdm7   sdo13  sdp7
sda8   sdc14  sdd8   sdf14  sdg8   sdi14  sdj8   sdl14  sdm8   sdo14  sdp8
sda9   sdc15  sdd9   sdf15  sdg9   sdi15  sdj9   sdl15  sdm9   sdo15  sdp9
sdb    sdc2   sde    sdf2   sdh    sdi2   sdk    sdl2   sdn    sdo2
sdb1   sdc3   sde1   sdf3   sdh1   sdi3   sdk1   sdl3   sdn1   sdo3
sdb10  sdc4   sde10  sdf4   sdh10  sdi4   sdk10  sdl4   sdn10  sdo4
sdb11  sdc5   sde11  sdf5   sdh11  sdi5   sdk11  sdl5   sdn11  sdo5
sdb12  sdc6   sde12  sdf6   sdh12  sdi6   sdk12  sdl6   sdn12  sdo6
sdb13  sdc7   sde13  sdf7   sdh13  sdi7   sdk13  sdl7   sdn13  sdo7
sdb14  sdc8   sde14  sdf8   sdh14  sdi8   sdk14  sdl8   sdn14  sdo8
sdb15  sdc9   sde15  sdf9   sdh15  sdi9   sdk15  sdl9   sdn15  sdo9
As you can see, it only goes up to sdp15, meaning that there is no sdp16 and
there is also no device higer than sdp.

A 2.4 based system supports many more SCSI devices...up to sddx.  I think your
only option here is to use 7.1, or use 7.0 to do a base install, then upgrade to
the 2.4 kernel and configure your system the way you want it.  At any rate, I
think you're going to wind up needing the 2.4 kernel.


Note You need to log in before you can comment on or make changes to this bug.