Bug 500863 - qemu -kernel/-initrd with 4Gb memory and F6 image results in "initramfs bad gzip magic"
qemu -kernel/-initrd with 4Gb memory and F6 image results in "initramfs bad g...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-14 11:21 EDT by Daire Byrne
Modified: 2009-06-15 22:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.10.5-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 22:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daire Byrne 2009-05-14 11:21:13 EDT
Description of problem:
When booting a Fedora 6 image (2.6.20) using -kernel and -initrd the kernel complains that the initrd passed to it isn't a valid gzip cpio disk image (it is). If I boot the *exact* same kernel and initrd using PXE (same kernel command line) it works fine.

The error is:

checking if image is initramfs...it isn't (bad gzip magic numbers); looks like an initrd

Fedora 3 and Fedora 11 images boot fine with -kernel and -initrd. This did not happen in Fedora 10. It also was happening before I updated for the fix to #499666.

Version-Release number of selected component (if applicable):
[root@sys422 ~]# rpm -qa | grep qemu
qemu-img-0.10-18.fc11.x86_64
qemu-system-x86-0.10-18.fc11.x86_64
qemu-common-0.10-18.fc11.x86_64

[root@sys422 ~]# uname -r
2.6.29.1-111.fc11.x86_64

How reproducible:
Always when booting Fedora 6 (2.6.20?) with -kernel and -initrd.

Steps to Reproduce:
1.Boot a Fedora 6 kernel and (custom) initrd
2.
3.
  
Actual results:
Cannot mount the initrd

Expected results:
Same as for PXE booting the same files - mounts initrd fine

Additional info:
Works fine when booting same files using PXE rom. It looks like this bug has appeared before, namely #237879
Comment 1 Mark McLoughlin 2009-05-14 11:50:49 EDT
Interesting bug, thanks Daire.

I've just tried with the installer kernel/initrd from Fedora 6:

  http://archives.fedoraproject.org/pub/archive/fedora/linux/core/6/x86_64/os/images/pxeboot/

and it works fine.

Anything special about this initrd? Perhaps you could post it somewhere for us to try?
Comment 2 Daire Byrne 2009-05-14 12:31:27 EDT
Mark,

(In reply to comment #1)
> Anything special about this initrd? Perhaps you could post it somewhere for us
> to try?  

It is a basic uClibc (buildroot) initrd which is turned into an initrd with:

  find ./ | cpio -H newc -o > /tmp/new-initrd.cpio ; gzip /tmp/new-initrd.cpio

It is 5MB after it has been compressed. I can send you the exact initrd if you want but you can probably make one quite quickly with buildroot:

  http://buildroot.uclibc.org/downloads/snapshots

The exact kernel version I'm using is "2.6.20-1.2948".

On further examination it seems to be related to the memory allocation. I just noticed that I had increased the memory >4G after upgrading to F11 and when I now drop it below 4G the FC6 boots correctly again. This is only for FC6 - F11 and FC3 both boot fine with >4G. So in summary this boots fine:

  <memory>3478528</memory>
  <currentMemory>3478528</currentMemory>

and this doesn't:

  <memory>4369408</memory>
  <currentMemory>4369408</currentMemory>

For now I'm happy to keep to Memory below 4G.
Comment 3 Mark McLoughlin 2009-05-14 12:50:09 EDT
Ah, nice catch

tried again with the stock Fedora 6 images:

$> qemu-kvm -m 4096 -kernel vmlinuz -initrd initrd.img -append 'console=ttyS0' -serial stdio
...
checking if image is initramfs...it isn't (bad gzip magic numbers); looks like an initrd

$> qemu-kvm -m 3072 -kernel vmlinuz -initrd initrd.img -append 'console=ttyS0' -serial stdio
...
anaconda installer init version 11.1.1.3 using a serial console
remember, cereal is an important part of a nutritionally balanced breakfast.
Comment 4 Glauber Costa 2009-05-18 20:39:12 EDT
patch sent upstream:

http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00812.html
Comment 5 Mark McLoughlin 2009-05-22 11:44:36 EDT
This will be in qemu-0.10.5 which we hope to push next week
Comment 6 Fedora Update System 2009-05-31 11:34:44 EDT
qemu-0.10.5-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.5-1.fc11
Comment 7 Fedora Update System 2009-06-02 10:29:48 EDT
qemu-0.10.5-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5776
Comment 8 Fedora Update System 2009-06-03 12:21:09 EDT
qemu-0.10.5-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.5-2.fc11
Comment 9 Bug Zapper 2009-06-09 11:49:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2009-06-15 22:28:06 EDT
qemu-0.10.5-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.