Bug 500890 - [patch] can't edit sheet after reopening from "recent"
[patch] can't edit sheet after reopening from "recent"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 14:24 EDT by Hubert Figuiere
Modified: 2009-11-11 19:53 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.8.4-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 21:36:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Figuiere 2009-05-14 14:24:26 EDT
Start gnumeric

Re-open a recently opened sheet. 

At that point most edit commands are disabled.

This is a known bug upstream, fixed in the 1.8 branch in git.

Patch 9932dc2cafe66b752e965175a3cbe9889819feb5 in git seems to fix the problem (I tried with and without) and therefor, unless there is a release of 1.8.5, I think it should be included in the package as it is major functionality break.

http://git.gnome.org/cgit/gnumeric/commit/?h=gnumeric-1-8&id=9932dc2cafe66b752e965175a3cbe9889819feb5
Comment 1 Bug Zapper 2009-06-09 11:50:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Danilo Câmara 2009-06-15 12:17:01 EDT
I can't edit any saved file, not only "recently opened sheet". In Fedora 10 gnumeric was fine.
Comment 3 Hubert Figuiere 2009-06-15 12:23:03 EDT
(In reply to comment #2)
> I can't edit any saved file, not only "recently opened sheet". In Fedora 10
> gnumeric was fine.  

That's exactly this bug.
Comment 4 Levente Farkas 2009-08-02 05:36:18 EDT
any change for quick fix? i no longer able to use gnumeric!!!?
Comment 5 Danilo Câmara 2009-08-02 22:03:15 EDT
(In reply to comment #4)
> any change for quick fix? i no longer able to use gnumeric!!!?  

Since gnumeric is not usable I'm surprised to see how few people use it in Fedora 11. I rebuild the Fedora RPM with the patch mentioned above and it works.

Today I tried to install gnumeric-1.8.4-3.fc12.x86_64.rpm from hawhide but got:

ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by gnumeric-1:1.8.4-3.fc12.x86_64
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])

I don't know if it's intended for F11 anyway...
Comment 6 Hubert Figuiere 2009-08-03 00:03:04 EDT
There is an update in F11 to provide xz compression support for rpm packages. But I would be you, I wouldn't try this f12 package anyway.
Comment 7 Joshua BA 2009-08-03 00:27:10 EDT
A usable workaround I have found for this bug is to enter a value into a cell (doesn't matter what or which) on the new document it presents you upon loading. After you do that if you open another document, it should let you edit it as normal (you can close without saving the document it starts up with after this without bad things happening).

P.S.
Be sure that you don't just type something and try to open the document. Hit enter or click on another cell first to fully set the contents. It won't work otherwise.
Comment 8 Huzaifa S. Sidhpurwala 2009-08-03 07:14:07 EDT
Hi Hubert,
I have put this patch is a scratch build at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1575314

Can you please test if this works for you.
I can then import it into rawhide as well as the F11 tree?
Comment 9 Levente Farkas 2009-08-03 07:49:18 EDT
working for me:-)
Comment 10 Levente Farkas 2009-10-11 18:04:12 EDT
when would you like to release this build?
unfortunately that build no longer available:-(
Comment 11 Fedora Update System 2009-10-12 03:56:04 EDT
gnumeric-1.8.4-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-3.fc11
Comment 12 Fedora Update System 2009-10-12 03:56:10 EDT
gnumeric-1.8.4-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-4.fc12
Comment 13 Huzaifa S. Sidhpurwala 2009-10-12 03:57:14 EDT
Sorry for the delay, the rpms are build and are in bodhi for testing.
Can you please comment on the above links so that it can be pushed to stable?
Thanks.
Comment 14 Fedora Update System 2009-10-13 21:35:53 EDT
gnumeric-1.8.4-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-10-20 18:49:56 EDT
gnumeric-1.8.4-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-5.fc11
Comment 16 Fedora Update System 2009-10-20 19:14:28 EDT
gnumeric-1.8.4-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-5.fc10
Comment 17 Fedora Update System 2009-11-11 19:51:27 EST
gnumeric-1.8.4-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2009-11-11 19:52:53 EST
gnumeric-1.8.4-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.