Bug 500935 - e2fsck won't fix my ext4 filesystem
e2fsck won't fix my ext4 filesystem
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 19:47 EDT by Nathan G. Grennan
Modified: 2009-05-20 16:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 16:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2009-05-14 19:47:02 EDT
Description of problem:
e2fsprogs-1.41.5 has necessary bug fixes for ext4, and needs to be upgrade to.
Comment 1 Nathan G. Grennan 2009-05-14 22:38:46 EDT
  Here is the text from upstream about the exact issue I ran into with 1.41.4's fsck that 1.41.5's fsck fixes.

Debugfs can now set i_file_acl_high via the set_inodes_field command, and print a 64-bit file acl. This is useful for debugging filesystem corruptions where the high bits of i_file_acl_high are set. E2fsck will detect and fix non-zero i_file_acl_high on 32-bit filesystems since some Linux kernel versions pay attention to this field even when they shouldn't.
Comment 2 Eric Sandeen 2009-05-14 22:55:07 EDT
So, this is the upstream fix:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=a9e817425dc0baede8ebe5fbc9984a640257432b

and I think it's a good idea to pull this back pre-F11 so that repair disks are more robust ....

-Eric
Comment 3 Eric Sandeen 2009-05-15 00:33:08 EDT
Ok, building in 1.41.4-9.fc11

I'll petition the release folks to include it.
Comment 4 Eric Sandeen 2009-05-20 16:38:46 EDT
1.41.4-9.fc11 is tagged for F11

Note You need to log in before you can comment on or make changes to this bug.