This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 500936 - Laptop LCD brightness set to 50% on boot, regardless of AC power presence
Laptop LCD brightness set to 50% on boot, regardless of AC power presence
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 20:07 EDT by Bruno Antunes
Modified: 2014-06-16 09:36 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:33:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Antunes 2009-05-14 20:07:34 EDT
Description of problem:
Udev sets laptop LCD brightness to 50% on startup, regardless of AC power presence.

Version-Release number of selected component (if applicable):
Rawhide

How reproducible:
Start Fedora up on a laptop, the LCD panel goes to 50% brightness upon startup.
  
Actual results:
Even with AC power connected, panel is dimmed and must be set to full brightness EVERY TIME it boots.

Expected results:
Check if there's AC power present, and dim the panel in case it isn't. Or just do nothing, and wait for Gnome or KDE to do it.

Additional info:
Laptop model is Acer Aspire 6930G. x86_64 kernel. Udev version 141-3.fc11. Kernel 2.6.29.3-140.fc11.
Comment 1 Harald Hoyer 2009-05-15 02:28:07 EDT
udev does not set anything related to this. This is either the kernel default, or some HAL mechanism sets it.
Comment 2 Richard Hughes 2009-05-15 04:12:34 EDT
Is it set at 50% as soon as Linux is booting, or only when gnome logs in?
Comment 3 Bruno Antunes 2009-05-15 05:07:12 EDT
As soon as it boots! I removed "quiet" from the kernel command line and it happens immediately after the udev service starts.
Comment 4 Harald Hoyer 2009-05-15 05:15:05 EDT
udev might load a kernel module, which then sets the initial value
Comment 5 Bruno Antunes 2009-05-15 05:20:59 EDT
My lsmod:

ipv6                  290112  32 
cpufreq_ondemand        7696  2 
acpi_cpufreq            9832  0 
freq_table              4816  2 cpufreq_ondemand,acpi_cpufreq
fuse                   57904  4 
dm_multipath           16168  0 
uinput                  8704  0 
arc4                    2080  2 
ecb                     3184  2 
uvcvideo               57180  0 
snd_hda_codec_nvhdmi     3536  1 
videodev               38704  1 uvcvideo
snd_hda_codec_realtek   265044  1 
v4l1_compat            13076  2 uvcvideo,videodev
iwlagn                149764  0 
iwlcore               135652  1 iwlagn
snd_hda_intel          29000  2 
v4l2_compat_ioctl32    10480  1 videodev
lib80211                6356  1 iwlcore
snd_hda_codec          65376  3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
mac80211              199552  2 iwlagn,iwlcore
usb_storage           101472  0 
snd_hwdep               8600  1 snd_hda_codec
snd_pcm                79960  2 snd_hda_intel,snd_hda_codec
snd_timer              22496  1 snd_pcm
iTCO_wdt               13120  0 
video                  21436  0 
joydev                 11584  0 
atl1e                  33876  0 
iTCO_vendor_support     3476  1 iTCO_wdt
acer_wmi               17464  0 
snd                    65096  10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
i2c_i801               10064  0 
serio_raw               6228  0 
pcspkr                  2848  0 
wmi                     7120  1 acer_wmi
soundcore               7024  1 snd
output                  3184  1 video
cfg80211               37024  3 iwlagn,iwlcore,mac80211
snd_page_alloc          9216  2 snd_hda_intel,snd_pcm
xts                     3600  1 
gf128mul                7456  1 xts
aes_x86_64              8144  2 
aes_generic            27648  1 aes_x86_64
dm_crypt               13000  1 
nouveau               470464  2 
drm                   205900  2 nouveau
i2c_algo_bit            5972  1 nouveau
i2c_core               22240  4 i2c_i801,nouveau,drm,i2c_algo_bit
Comment 6 Bug Zapper 2009-06-09 11:50:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Scott Glaser 2009-09-09 09:45:27 EDT
Have you tried with the latest hal package in Fedora 11 or tried Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 collura 2009-10-16 02:16:50 EDT
still happening

seem to be using: 
hal-0.5.12-29.20090226git.fc11 (x86_64)
hal-devel-0.5.12-29.20090226git.fc11 (x86_64)
hal-info-20090414-1.fc11 (noarch)
hal-libs-0.5.12-29.20090226git.fc11 (x86_64)


havent tried rawhide.

hmm, the wierd part is that a later version of the 'same' make/model machine doenst have the problem (same version of hal but doesnt have hal-devel installed....i havent tried removing this on broken one because dont remember why its there).
Comment 9 collura 2009-10-24 12:01:04 EDT
seems to have problems with fc12alpha x86_64 livecd ( 11.91 ) i downloaded like
10-16-09

when booting it gives me:

"[drm: radeon_driver_load_kms] *ERROR* failed to initialize radeon disabling
IOCTL"
Comment 10 collura 2009-12-03 19:12:52 EST
ok i still have the forgetful brightness meter problem on one machine with
fc11.

now a duplicate machine that had not experienced the problem with fc11 is now
having the forgetfulness problem since i installed fc12 on it last week.  

the good news being that as of the fc12 install last week the '[drm: radeon_driver_load_kms]' error is gone.

although brightness doenst work right at least have one less error message.
Comment 11 Bug Zapper 2010-04-27 10:20:09 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 collura 2010-04-27 12:59:34 EDT
still doesnt work.

hal-0.5.13-9.fc12 (x86_64)
kernel-2.6.32.11-99.fc12 (x86_64)
Comment 13 collura 2010-04-28 12:54:52 EDT
please change the version to fc12
Comment 14 Bug Zapper 2010-06-28 08:33:06 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 15 Bruno Antunes 2014-06-16 09:36:32 EDT
Just posting this in the hopes of getting Bugzilla off my back for this 5 year old report...

Note You need to log in before you can comment on or make changes to this bug.