Bug 500947 - Installer can't locate SATA hard drive (block.device = '/dev/sda').
Installer can't locate SATA hard drive (block.device = '/dev/sda').
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:05f1007305d43c29b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 00:26 EDT by Colin Leavett-Brown
Modified: 2009-05-15 08:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 08:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (54.32 KB, text/plain)
2009-05-15 00:26 EDT, Colin Leavett-Brown
no flags Details
lshal output after booting from Live CD. (157.03 KB, application/octet-stream)
2009-05-15 00:59 EDT, Colin Leavett-Brown
no flags Details

  None (edit)
Description Colin Leavett-Brown 2009-05-15 00:26:19 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/__init__.py", line 277, in freshDisk
    peddisk = disk_new_fresh(device.getPedDevice(), ty)
  File "/usr/lib/anaconda/storage/devices.py", line 682, in __init__
    ty = platform.getPlatform(None).diskType)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1064, in addUdevDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1486, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 265, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 90, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Can't write to /dev/fd0, because it is opened read-only.
Comment 1 Colin Leavett-Brown 2009-05-15 00:26:24 EDT
Created attachment 344075 [details]
Attached traceback automatically from anaconda.
Comment 2 Colin Leavett-Brown 2009-05-15 00:58:16 EDT
Auto-anaconda trace occurred after the following:
1. Booted from F11 Beta installation DVD.
2. Selected option #1, Graphical Installation.
3. Language: US English.
4. Keyboard: US English.
5. Finding Storage Device..... (several minutes).
6. Warning: Error processing drive fd0. Maybe it needs to be re-initialized. YOU WILL LOOSE ALL DATA ON THIS DRIVE. Ignore Drive or Re-initialize Drive? Reinitialize chosen.
7. Exception occurred and bug filed.
8. Subsequently rebooted using the Live CD using same hardware configuration. Ran "lshal >/media/disk/lshal" and will attach the results next.
Comment 3 Colin Leavett-Brown 2009-05-15 00:59:26 EDT
Created attachment 344076 [details]
lshal output after booting from Live CD.
Comment 4 Chris Lumens 2009-05-15 08:25:46 EDT
This is fixed after the beta, which is really quite old at this point.  We've done a ton of partition-related fixes since then.

Note You need to log in before you can comment on or make changes to this bug.