Bug 500969 - Error when recompile dbus-python-0.70-7.el5.src.rpm [NEEDINFO]
Error when recompile dbus-python-0.70-7.el5.src.rpm
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus-python (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Depends On:
  Show dependency treegraph
Reported: 2009-05-15 04:25 EDT by Shining
Modified: 2014-06-02 09:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-02 09:07:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (nshi_nb)

Attachments (Terms of Use)

  None (edit)
Description Shining 2009-05-15 04:25:50 EDT
Description of problem:
When I try to recompile dbus-python-0.70-7.el5.src.rpm,the following error message is shown.
running build
running build_py
creating build
creating build/lib.linux-i686-2.4
creating build/lib.linux-i686-2.4/dbus
copying dbus/_dbus.py -> build/lib.linux-i686-2.4/dbus
copying dbus/exceptions.py -> build/lib.linux-i686-2.4/dbus
copying dbus/glib.py -> build/lib.linux-i686-2.4/dbus
copying dbus/__init__.py -> build/lib.linux-i686-2.4/dbus
copying dbus/matchrules.py -> build/lib.linux-i686-2.4/dbus
copying dbus/service.py -> build/lib.linux-i686-2.4/dbus
copying dbus/types.py -> build/lib.linux-i686-2.4/dbus
copying dbus/decorators.py -> build/lib.linux-i686-2.4/dbus
copying dbus/introspect_parser.py -> build/lib.linux-i686-2.4/dbus
copying dbus/proxies.py -> build/lib.linux-i686-2.4/dbus
copying dbus/_util.py -> build/lib.linux-i686-2.4/dbus
running build_ext
building 'dbus/dbus_bindings' extension
/usr/src/redhat/BUILD/dbus-python-0.70/dbus/dbus_bindings.pxd:71:93: Expected ')'
/usr/src/redhat/BUILD/dbus-python-0.70/dbus/dbus_bindings.pyx:56:37: Syntax error in C variable declaration
error: Bad exit status from /var/tmp/rpm-tmp.95984 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.95984 (%build)

Version-Release number of selected component (if applicable):
uname -a
Linux atsbox.insigma.com 2.6.18-128.el5 #1 SMP Wed Dec 17 11:42:39 EST 2008 i686 i686 i386 GNU/Linux
rpm -qi gcc
Name        : gcc                          Relocations: (not relocatable)
Version     : 4.1.2                             Vendor: Red Hat, Inc.
Release     : 44.el5                        Build Date: Fri 19 Sep 2008 02:07:01 AM CST
Install Date: Fri 15 May 2009 03:29:50 PM CST      Build Host: ls20-bc2-14.build.redhat.com
Group       : Development/Languages         Source RPM: gcc-4.1.2-44.el5.src.rpm
Size        : 10087453                         License: GPL
Signature   : DSA/SHA1, Mon 08 Dec 2008 08:28:52 PM CST, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://gcc.gnu.org
Summary     : Various compilers (C, C++, Objective-C, Java, ...)
Description :
The gcc package contains the GNU Compiler Collection version 4.1.
You'll need this package in order to compile C code.
rpm -qi dbus-glib-devel
Name        : dbus-glib-devel              Relocations: (not relocatable)
Version     : 0.73                              Vendor: Red Hat, Inc.
Release     : 8.el5                         Build Date: Tue 16 Sep 2008 05:04:58 AM CST
Install Date: Fri 15 May 2009 02:55:35 PM CST      Build Host: hs20-bc2-3.build.redhat.com
Group       : Development/Libraries         Source RPM: dbus-glib-0.73-8.el5.src.rpm
Size        : 261262                           License: AFL/GPL
Signature   : DSA/SHA1, Tue 09 Dec 2008 03:57:12 AM CST, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.freedesktop.org/software/dbus/
Summary     : Libraries and headers for the D-Bus GLib bindings
Description :

Headers and static libraries for the D-Bus GLib bindings
rpm -qi Pyrex
Name        : Pyrex                        Relocations: (not relocatable)
Version     : 0.9.4                             Vendor: Red Hat, Inc.
Release     : 2.fc6                         Build Date: Sat 23 Sep 2006 09:29:45 AM CST
Install Date: Fri 15 May 2009 02:42:10 PM CST      Build Host: js20-bc2-10.build.redhat.com
Group       : Development/Languages         Source RPM: Pyrex-0.9.4-2.fc6.src.rpm
Size        : 1629579                          License: Public Domain
Signature   : DSA/SHA1, Thu 18 Jan 2007 11:29:22 PM CST, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
Summary     : A compiler/language for writing Python extension modules.
Description :
Pyrex is Python with C types.  It is specially designed to allow you to
write extension modules for Python that have the speed of C and the
simplicity and readability of Python.  You write your code in a Python-like
language with C-typed variables, then use the pyrexc compiler to transform
it into a C representation.  This is useful for speeding up critical sections
of your Python code or wrapping an external library.

Please see the documentation for how to get the best performance from your

How reproducible:

Steps to Reproduce:
1. cd /usr/src/redhat/SPECS
2. rpmbuild -bb dbus-python.spec
Actual results:

Expected results:

Additional info:
Comment 1 Tomo Vuckovic 2009-11-06 14:25:08 EST
change spec file to :


pushd dbus
    pyrexc dbus_bindings.pyx
    pyrexc dbus_glib_bindings.pyx

CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
Comment 3 RHEL Product and Program Management 2014-03-07 08:39:07 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:07:34 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.