Bug 500970 - Adding liveuser in /etc/rc.d/init.d/livesys is incompatible with LDAP auth
Adding liveuser in /etc/rc.d/init.d/livesys is incompatible with LDAP auth
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 04:26 EDT by James Heather
Modified: 2009-08-12 18:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-12 18:32:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Heather 2009-05-15 04:26:45 EDT
Description of problem:
The user 'liveuser' gets added in /etc/rc.d/init.d/livesys, which is put there by fedora-live-base.ks, which is the base kickstart file for other live builds.

It works fine when just using local authentication, but if LDAP (or presumably anything else) is turned on, then it causes problems when livesys tries to add the user, because it tries to add it on the LDAP server rather than just locally. This is a shame: it ought to be possible to use fedora-live-base.ks as an include file for a live build that uses LDAP.

Is there any reason for adding liveuser so late in the day? Wouldn't it be better if it were added in the %post script? That way, the user would already exist when the system boots up, and the problem wouldn't arise.

Version-Release number of selected component (if applicable):
0.10.3-3

How reproducible:
Always

Steps to Reproduce:
1. Make a kickstart file that has the lines

%include /path/to/fedora-live-base.ks

auth --useshadow --enablemd5 --enablecache --enableldap --enableldapauth --enablelocauthorize --ldapserver=blah.com --ldapbasedn="dc=blah,dc=com"

2. Use livecd-creator to build the image

3. Boot up from new image

4. Sob for mummy
  
Actual results:
Hangs at the line 'Adding live user'

Expected results:
Boots up normally

Additional info:
I suspect this applies to rawhide too but I have not been able to check this.
Comment 1 Jeroen van Meeuwen 2009-08-12 18:32:09 EDT
If you modify the auth to go through LDAP, then maybe also edit /etc/init.d/livesys to not create a user.

Note You need to log in before you can comment on or make changes to this bug.