Bug 500983 - hibernate: intel: Kernel panics on with Intel graphics and mode setting on thaw
hibernate: intel: Kernel panics on with Intel graphics and mode setting on thaw
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 06:56 EDT by Bojan Smojver
Modified: 2010-06-28 08:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -vv (21.45 KB, text/plain)
2009-05-15 06:56 EDT, Bojan Smojver
no flags Details
/var/log/messages (57.60 KB, application/x-bzip2)
2009-05-16 03:08 EDT, Bojan Smojver
no flags Details
Screen shot of the crash on thaw (572.58 KB, image/jpeg)
2009-05-27 19:57 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2009-05-15 06:56:01 EDT
Created attachment 344119 [details]
Output of lspci -vv

Description of problem:
If the system is hibernated and then thawed, we come to the gnome-screensaver screen is required. After punching in the password, the system keeps flickering the VT1 screen on every move of the mouse. Other screens are OK (using CTRL-ALT-Fx sequence), but one cannot login. Compiz was in use on this system. This happens with both tiling enabled and disabled. When boot option nomodeset is passed, the system works fine.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29.3-140.fc11.i686

How reproducible:
Always.

Steps to Reproduce:
1. Boot into Gnome (compiz).
2. Hibernate.
3. Thaw, type the password to unlock and observe.
  
Actual results:
Kernel panics.

Additional info:
This is a Dell Inspiron 6400.
Comment 1 Bojan Smojver 2009-05-15 06:56:58 EDT
> If the system is hibernated and then thawed, we come to the gnome-screensaver
screen is required.

Sorry - I had a nonsense moment :-( Ignore the last few words...
Comment 2 Adam Williamson 2009-05-15 22:35:47 EDT
Is this a regression from the previous fc11 kernel? Or has it been like this for a while?

Can you try it with 142 and see if it works with that? You can get it from Koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=101949
Comment 3 Bojan Smojver 2009-05-16 01:41:44 EDT
Not sure if this is a regression. I just upgraded this box to Rawhide (a.k.a. F-11).

I'll try 142 and let you know, but other folks already reported that it didn't work for them on ATI hardware. Not sure if that's related or not.
Comment 4 Bojan Smojver 2009-05-16 03:08:19 EDT
142 is marginally better, but the system is still unusable. I can type in the password and there is not screen flickering, but I get this on the console:

init[1]: segfault at 1 ip 08059c10 sp <various_hex> error 6 in init[8048000+20000]

This is accompanied by beeps at regular intervals (about 5 seconds). System is screwed - login doesn't work on other VTs, programs segfault immediately when run etc.

I'll attach my messages file. There should be more interesting stuff in there.
Comment 5 Bojan Smojver 2009-05-16 03:08:48 EDT
Created attachment 344260 [details]
/var/log/messages
Comment 6 Bojan Smojver 2009-05-16 03:10:59 EDT
Oh, and disk is going berserk when all this starts happening. Not exactly sure why...
Comment 7 Bojan Smojver 2009-05-19 17:40:57 EDT
Anything in -152 that is related to this?
Comment 8 Bojan Smojver 2009-05-20 01:31:28 EDT
No dice - 152 is still causing all programs to die. I do get the desktop and I can click on the menu items, but nothing runs. I also cannot login to any other VT.
Comment 9 Bojan Smojver 2009-05-20 19:55:47 EDT
Kernel -155 gives blank screen on thaw. Changing VTs is not possible (still blank screen).
Comment 10 Kyle McMartin 2009-05-22 15:47:57 EDT
Can't reproduce this on x86_64 with any kernel I have installed (-140 to latest) on 965GM...
Comment 11 Bojan Smojver 2009-05-22 19:00:22 EDT
Both machines in question are not 64-bit capable. Kernel is i686 PAE kernel.
Comment 12 Kyle McMartin 2009-05-22 19:17:04 EDT
In that case, can you try with the i586 kernel?
Comment 13 Bojan Smojver 2009-05-22 19:21:34 EDT
OK, shall do.

BTW, is there something in -159 that may improve this?
Comment 14 Kyle McMartin 2009-05-22 19:26:01 EDT
No, not likely, but it's worth a shot.
Comment 15 Bojan Smojver 2009-05-22 20:17:59 EDT
Yeah, i586 kernel works. I tried with -155. So, definitely an i686 PAE thing.
Comment 16 Bojan Smojver 2009-05-27 19:57:44 EDT
Created attachment 345688 [details]
Screen shot of the crash on thaw

-167 kernel is a lot better. I was able to hibernate/thaw once and get a fully functional system. However, when I attempted to do it the second time, I got the attached screen on thaw and completely frozen system.
Comment 17 Bug Zapper 2009-06-09 11:52:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Andrew Duggan 2009-07-07 12:45:32 EDT
This still happens with 2.6.29.6-211.fc11.i586.  I have an Inspiron 1505 1GB BCM4311 which is the same as a 6400.  

Sometimes the first hibernate/thaw cycle works, but never been able to get more than one cycle.  

Jul  7 09:17:54 apd-dell1 kernel: ld-linux.so.2[4704]: segfault at 2 ip 00aad018 sp bfff8abc error 6 in ld-2.10.1.so[a96000+20000]
Jul  7 09:18:42 apd-dell1 kernel: ld-linux.so.2[5031]: segfault at 2 ip 00aad018 sp bfec6df8 error 6 in ld-2.10.1.so[a96000+20000]
Jul  7 09:19:12 apd-dell1 init: Re-executing /sbin/init
Jul  7 09:23:07 apd-dell1 kernel: hrtimer: interrupt too slow, forcing clock min delta to 4910565 ns

I have sysreq tracebacks if you want them

This system was upgraded from F10.  Ran memtest86+ (passed) 
/proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
stepping	: 6
cpu MHz		: 1000.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm tpr_shadow
bogomips	: 3657.40
clflush size	: 64
power management:
--snip--
Comment 19 Bojan Smojver 2009-07-16 02:00:24 EDT
Were there some .31 kernel fixes in this area? Anything that can get backported?
Comment 20 Adam Williamson 2009-07-16 19:18:04 EDT
You could try booting a .31 kernel and see. I've seen a report in another bug that you can boot the latest Rawhide .31 kernel on F11 and it'll work.

(don't do this if you're using btrfs, but if you're using btrfs you deserve all you get :>)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Bojan Smojver 2009-07-16 19:23:11 EDT
OK, that sounds reasonable. I don't have btrfs, so it should be all good.
Comment 22 Bojan Smojver 2009-07-16 20:54:27 EDT
Nah, that didn't work. Can't even get X to start:
----------------------
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, IGD_GM, IGD_G, 965G, G35,
        965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        Mobile Intel® GM45 Express Chipset,
        Intel Integrated Graphics Device, G45/G43, Q45/Q43, G41
(EE) No devices detected.

Fatal server error:
no screens found
----------------------

I'm guessing I have to wait until that gets fixed up.
Comment 23 Adam Williamson 2009-07-16 22:07:42 EDT
yeah...maybe there's kernel-side changes in 2.6.31 that need a changed driver too.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Andrew Duggan 2009-07-22 18:29:25 EDT
Try kernel-2.6.31-0.81.rc3.git4.fc12.i686 and kernel-firmware-2.6.31-0.81.rc3.git4.fc12.noarch

I tested from run level 3 and successfully hibernated and resumed 5 times, without any segfaults.   I rebooted to RL 5 and X and compiz both work and I've hibernated and resumed 3 times already.   So this may be better. 

Now I'm going to see how well I do with cpuspeed running and the acpi_cpufreq module loaded across the hibernate/resume cycle.  If that goes OK, I'm going to try re-enabling exec shield, and reinstalling prelink, not that I think that will be a problem.

Today's kernel build from Koji hadn't finished when I tried this, so that one may work, but YMMV.

There may be hope yet.
Comment 25 Bojan Smojver 2009-07-22 18:36:44 EDT
Thanks for the tip Andrew.
Comment 26 Bojan Smojver 2009-08-19 05:32:35 EDT
2.6.30.5-32.fc11 is still no good. Flickering screen on thaw. Cannot login when I switch to another console.
Comment 27 Bojan Smojver 2009-09-26 00:02:06 EDT
Kernel kernel-PAE-2.6.30.8-64.fc11.i686 is a lot better than anything before. I was able to do this:

- hibernate/thaw
- hibernate/thaw
- suspend/resume
- hibernate

When attempted another thaw at that point, X hung (i.e. no prompt to login) and there were beeps coming from the system. I could not switch to a text console. Logs didn't reveal anything unusual - the system just hung.

So, closer, but not quite there.
Comment 28 Bojan Smojver 2009-11-12 01:28:44 EST
Just bumped up one of the machines to F-12 and although there is no panic, on second thaw programs start crashing (segfaults in things like egrep, for instance). Hibernation is impossible at that point. Kernel is 2.6.31.5-127.fc12.

Almost there again...
Comment 29 Bojan Smojver 2009-11-13 15:54:41 EST
I opened bug #537494, which is more or less this same thing for F-12 (with slightly different symptoms).
Comment 30 Bug Zapper 2010-04-27 10:20:29 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 Bug Zapper 2010-06-28 08:33:20 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.