Bug 500985 - Upgrade in stable release broke my gallery AGAIN
Upgrade in stable release broke my gallery AGAIN
Status: CLOSED DUPLICATE of bug 498334
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-05-15 07:06 EDT by David Woodhouse
Modified: 2009-05-15 07:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-15 07:59:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-05-15 07:06:50 EDT
file_exists(/srv/gallery2/g2data_5yvrt3w4/cache/module/_all/0/0/GalleryFactoryHelper_loadRegistry.inc) Unimplemented: GalleryUrlGenerator getParameter language.useBrowserPref for core plugin file_exists(/srv/gallery2/g2data_5yvrt3w4/cache/module/core/0/0/0.inc) controller , view Loading plugin core Class not defined, trying to include it. file_exists(/usr/share/gallery2/modules/core/module.inc) core plugin successfully instantiated file_exists(/srv/gallery2/g2data_5yvrt3w4/versions.dat) file(/srv/gallery2/g2data_5yvrt3w4/versions.dat, ) getParameter id.anonymousUser for core plugin [1242385319] can't guarantee 5 -- extending! file_exists(/srv/gallery2/g2data_5yvrt3w4/cache/entity/0/0/5.inc) Loading plugin core core plugin successfully instantiated Check the version of the core plugin file_exists(/srv/gallery2/g2data_5yvrt3w4/cache/module/_all/0/0/GalleryPluginHelper_fetchPluginStatus.inc) The version of the core plugin is ok file_exists(/usr/share/gallery2/modules/core/ShowItem.inc)
Warning: GalleryCoreApi::require_once(/usr/share/gallery2/modules/core/classes/../../../lib/smarty/Smarty.class.php) [gallerycoreapi.require-once]: failed to open stream: No such file or directory in /usr/share/gallery2/modules/core/classes/GalleryCoreApi.class on line 2827

Fatal error: GalleryCoreApi::require_once() [function.require]: Failed opening required '/usr/share/gallery2/modules/core/classes/../../../lib/smarty/Smarty.class.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/gallery2/modules/core/classes/GalleryCoreApi.class on line 2827
Comment 1 David Woodhouse 2009-05-15 07:26:27 EDT
Fixed by manually creating a symlink
/usr/share/gallery2/lib/smarty -> ../../php/Smarty
Comment 2 Gwyn Ciesla 2009-05-15 07:59:38 EDT

*** This bug has been marked as a duplicate of bug 498334 ***

Note You need to log in before you can comment on or make changes to this bug.