This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 500994 - plymouth-theme-spinfinity broken
plymouth-theme-spinfinity broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-05-15 08:19 EDT by Robert de Rooy
Modified: 2009-08-19 09:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 09:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert de Rooy 2009-05-15 08:19:37 EDT
Description of problem:
http://forums.fedoraforum.org/showthread.php?t=221763

/usr/share/plymouth/themes/spinfinity/spinfinity.plymouth contains an invalid reference to /usr/share/plymouth/themes/throbgress which does not exist.
Changing it to point to /usr/share/plymouth/themes/spinfinity and recreating the initrd makes plymouth graphical boot work again

Version-Release number of selected component (if applicable):
plymouth-theme-spinfinity-0.7.0-0.2009.05.14.2.fc11.i586

How reproducible:
Current plymouth spinfinity package is broken, including the latest from koji

Steps to Reproduce:
1. Install latest spinfinity package
2. Update kernel, or re-create initrd
3.
  
Actual results:
Plymouth text mode boot

Expected results:
Plymouth graphical boot with spinfinity theme

Additional info:
Comment 1 Ray Strode [halfline] 2009-05-15 09:59:47 EDT
Thank you for reporting this issue.
Comment 2 Ray Strode [halfline] 2009-05-15 10:25:37 EDT
Updated packages are here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=102239
Comment 3 cornel panceac 2009-05-19 22:42:39 EDT
still text progress bar with plymouth*2009.05.15.1*i586

it's a fresh f11 preview install (not coming from f10 or beta, etc), updated.
Comment 4 Ray Strode [halfline] 2009-05-21 11:02:01 EDT
you need to rebuild your initrd by installing a new kernel or running /usr/libexec/plymouth/plymouth-update-initrd before new plymouth installs take effect at boot up.
Comment 5 cornel panceac 2009-05-21 11:56:37 EDT
(In reply to comment #4)
> you need to rebuild your initrd by installing a new kernel or running
> /usr/libexec/plymouth/plymouth-update-initrd before new plymouth installs take
> effect at boot up.  

thank you, but rebuilding initrd was not enough. following these instructions from will woods (on fedora-devel-list) worked, 

# yum install plymouth-system-theme
# plymouth-set-default-theme charge
# /usr/libexec/plymouth/plymouth-update-initrd

but there's still no graphics on shutdown.
Comment 6 cornel panceac 2009-05-21 12:15:40 EDT
oh, after latest updates the shutdown is graphical too.
Comment 7 Bug Zapper 2009-06-09 11:52:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Robert de Rooy 2009-08-19 09:10:31 EDT
This issue was solved, so the bug can be closed

Note You need to log in before you can comment on or make changes to this bug.