Bug 500996 - virt-manager: VM does not scale to window size although scale->display is set to "always"
virt-manager: VM does not scale to window size although scale->display is set...
Status: CLOSED DUPLICATE of bug 491683
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 08:25 EDT by Stefan Assmann
Modified: 2009-05-25 10:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 10:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of vm after login (278.80 KB, image/png)
2009-05-15 08:25 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2009-05-15 08:25:24 EDT
Created attachment 344134 [details]
snapshot of vm after login

Description of problem:
virt-manager does not scale VM to window size correctly. I went to "preferences" and set graphical console scaling to "always". Start a plain RHEL5.3 VM. Scaling still works correctly (console messages show up, login screen looks fine too). After I log in it's not scaling correct anymore (can't see the bottom taskbar). Even changing window size does not help. (See screenshot)

How reproducible:
always

Steps to Reproduce:
1. set scale display to "always"
2. start plain RHEL5.3 VM
3. log in
  
Actual results:
can't see whole desktop of VM

Expected results:
desktop of VM is scaled according to window size

Additional info:
This is probably caused by low screen resolution. My display only supports 1024x768 while the RHEL5.3 in the VM has the same resolution by default (a guess).
Things look fine when I switch to fullscreen mode though.
Comment 1 Mark McLoughlin 2009-05-25 10:05:52 EDT
Thanks, this sounds like a bug which is fixed by virt-manager-0.7.0-5.fc11 in updates-testing:

https://admin.fedoraproject.org/updates/virt-manager-0.7.0-5.fc11

Please test out and add a +/- comment to the update

*** This bug has been marked as a duplicate of bug 491683 ***

Note You need to log in before you can comment on or make changes to this bug.