Bug 501014 - Add support for the SILI bit in mt-st.
Add support for the SILI bit in mt-st.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mt-st (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Dan Horák
Lukas Zachar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 10:16 EDT by Tom Coughlan
Modified: 2013-04-12 16:16 EDT (History)
6 users (show)

See Also:
Fixed In Version: mt-st-0.9b-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 08:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Coughlan 2009-05-15 10:16:32 EDT
In RHEL 5.4 we added support in the kernel for the SILI bit in st driver:

"Add new option MT_ST_SILI to enable setting the SILI bit in
reads in variable block mode. If SILI is set, reading a block shorter
than the byte count does not result in CHECK CONDITION. The length of
the block is determined using the residual count from the HBA. Avoiding
the REQUEST SENSE command for every block speeds up some real
applications considerably."

The current version of mt-st does not have a keyword for the sili bit. Instead, it must be enabled explicitly with: 

mt -f /dev/nst0 stsetoptions 0x4000

There is a new version of mt-st (mt-st-1.1) that adds a keyword for setting the SILI bit:

ftp.ibiblio.org/pub/linux/system/backup/

This would be much easier to use and less error-prone.

The new version also has the ability to display the current setting of all the option bits. (An additional kernel patch will be needed to enable this.) This would be helpful in general for our support folks. 

Please investigate updating the mt-st package, or backporting these specific features.
Comment 1 RHEL Product and Program Management 2009-05-15 10:17:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Tom Coughlan 2009-05-15 11:13:27 EDT
(In reply to comment #0)

> The new version also has the ability to display the current setting of all the
> option bits. (An additional kernel patch will be needed to enable this.) 

Bug 501030 -  Need to display the current settings of the options bits in st driver.
Comment 27 errata-xmlrpc 2012-08-14 08:06:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1167.html

Note You need to log in before you can comment on or make changes to this bug.