Bug 50102 - package installation failed
package installation failed
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: ipvsadm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 16:15 EDT by Florin Andrei
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 17:23:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2001-07-26 16:15:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
After i installed a new RH 7.1 system, i tried to install ipvsadm from the
Powertools CD, using "rpm -Uvh package-name". But i got this error:
-add: unknown option
error: execution of %post scriptlet from ipvsadm-1.14-5 failed, exit status 1

How reproducible:
Always

Steps to Reproduce:
1.install barebones RH7.1 (no package category selected, just basic packages)
2.try to install ipvsadm from Powertools
3.BOOM!
	

Actual Results:  it said there were some errors (see Description)

Expected Results:  package should install fine

Additional info:
Comment 1 Martin Stehr 2001-08-17 00:38:04 EDT
Previously I had kernel-2.2.16 installed and
choose the Redhat upgrade Option to RH 7.1

Now I have Redhat 7.1 installed and upgraded
from kernel-2.4.2-2 to kernel-2.4.3-12 
(through up2date agent, as a registered user)

The only RPM I couldn't upgrade is 
ipvsadm-1.1-2 to ipvsadm-1.14-5

up2date says:   dependency check error: ipvsadm-1.14-5 
requires piranha-0.4.14 installed

but up2date doesn't get piranha for me, so why does it
ask for it ???

Thanks,

Martin Stehr
mstehr@rdc.cl
Comment 2 Phil Copeland 2001-08-25 13:19:00 EDT
Peter, is RHN doing the right thing or is this some cross product fiasco that
needs addressing by your's truely???
Comment 3 Peter Jones 2001-12-06 19:14:21 EST
Nobody has pushed any piranha packages to RHN for the 7.1 distro.  You get this
one :)
Comment 4 James Manning 2002-03-25 17:23:52 EST
just ran across this one today updating an old 7.1 box

AFAICT, it's a damn simple fix - the postinstall does chkconfig -add (single hyphen)
instead of the correct chkconfig --add (double hyphen - adding the /sbin/ path
for chkconfig wouldn't hurt either)

[root@lvs01 up2date]# rpm -q ipvsadm
ipvsadm-1.14-5
[root@lvs01 up2date]# rpm -q --scripts ipvsadm
postinstall scriptlet (through /bin/sh):
chkconfig -add ipvsadm
preuninstall scriptlet (through /bin/sh):
if [ $1 = 0 ]; then     # execute this only if we are NOT doing an upgrade
        /sbin/service ipvsadm stop  >/dev/null 2>&1
        /sbin/chkconfig --del ipvsadm
fi
postuninstall scriptlet (through /bin/sh):
if [ "$1" -ge "1" ]; then
        service ipvsadm  condrestart >/dev/null 2>&1
fi

(that postuninstall looks odd, too, doing a restart, not stop, with the rc file
gone, but that's not what's breaking here)

I'd imagine the -add wouldn't break a whole lot since ppl still have to
chkconfig --level 2345 ipvsadm on or whatever, but I'd either WONTFIX
this or add the character, push the errata, and ERRATA it :) at least, imho

then again, I'm already on Bryce's sh*t-list for other reasons and maybe I really
shouldn't be commenting on this - do not taunt Happy Fun Bryce

ipvsadm - dirty like zebra, indeed
Comment 5 Phil Copeland 2002-03-26 15:02:23 EST
Die die die.... (ahem)
actually due to internal polictics, I make the packages available off
ftp://ftp.linux.org.uk/pub/linux/piranha
if you use the 2.2 kernel use the 6.2 directory otherwise use the 7.x directory
version of ipvsadm where all that is taken care of already

[root@parcelfarce ipvsadm]# rpm -qp --scripts ipvsadm-1.18-8.i386.rpm 
postinstall scriptlet (through /bin/sh):
/sbin/chkconfig --add ipvsadm
preuninstall scriptlet (through /bin/sh):
/sbin/chkconfig --del ipvsadm

hope thats of help

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.