Bug 501020 - pykickstart update broke existing part commands
pykickstart update broke existing part commands
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-05-15 10:29 EDT by Bruno Wolff III
Modified: 2009-05-19 14:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 14:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from livecd-creator (60.18 KB, text/plain)
2009-05-15 15:40 EDT, Bruno Wolff III
no flags Details
Kickstart used on the command line (2.19 KB, text/plain)
2009-05-15 15:41 EDT, Bruno Wolff III
no flags Details
First included kickstart (1.22 KB, text/plain)
2009-05-15 15:41 EDT, Bruno Wolff III
no flags Details
Nested included kickstart (12.32 KB, text/plain)
2009-05-15 15:42 EDT, Bruno Wolff III
no flags Details
livecd-creator output using pykickstart-1.52-2.fc11 (1.42 MB, text/plain)
2009-05-15 16:55 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-05-15 10:29:06 EDT
Description of problem:
The 1.53-1.fc11 update broke specifying size on existing kickstart files. Instead of getting the size you request, you get 4 GiB. I have been looking at some of the things that changed, but haven't figured out the exact issue. Since this might effect the RC Live Games Spin (it breaks my builds) I wanted to get this tracked now, even though I have some hope of figuring out what needs to change.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-05-15 14:48:43 EDT
Specifying size of what?  It helps to see the actual kickstart file.
Comment 2 Bruno Wolff III 2009-05-15 15:25:46 EDT
The / partition in the Live Games Spin kickstart file. In this case:
part / --size 10240

This used to make the install root bigger, but it no longer does.

I went and modified the default size for when no size was specified and it changed the size of the install root as shown by df when livecd-creator was running.

Some changes regarding how size was done happened about the same time. There is one suspect comparison between the string "self.size" and the number 0, but it was there before and changing it doesn't seem to matter.

I'll get you the error message and the exact kickstart after I do a reinstall to get rid of any of the testing changes I had been trying to figure out what's happening.
Comment 3 Bruno Wolff III 2009-05-15 15:40:26 EDT
Created attachment 344223 [details]
Output from livecd-creator
Comment 4 Bruno Wolff III 2009-05-15 15:41:20 EDT
Created attachment 344224 [details]
Kickstart used on the command line
Comment 5 Bruno Wolff III 2009-05-15 15:41:50 EDT
Created attachment 344225 [details]
First included kickstart
Comment 6 Bruno Wolff III 2009-05-15 15:42:22 EDT
Created attachment 344226 [details]
Nested included kickstart
Comment 7 Bruno Wolff III 2009-05-15 15:43:08 EDT
This is the command run:
livecd-creator -v -c fedora-livedvd-games.ks -f "Fedora-11-Live-games-x86_64" -t
 /home/livecd/tmp --cache=/home/livecd/cache
Comment 8 Bruno Wolff III 2009-05-15 15:57:49 EDT
I'll have a full example later (as it takes a while to run when it isn't broken), but for now I have downgraded pykickstart (using nodeps to work around an anaconda dependence) but used the same livecd-tools version and same kickstart files. Even at the start you can see that the install root size is larger.

[root@cerberus livegames]# ./run
mke2fs 1.41.4 (27-Jan-2009)
Filesystem label=Fedora-11-Live-g
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
655360 inodes, 2621440 blocks
26214 blocks (1.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=2684354560
80 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632

Writing inode tables: done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 32 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
tune2fs 1.41.4 (27-Jan-2009)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
filespec_eval:  hash table stats: 12 elements, 12/65536 buckets used, longest chain length 1
Retrieving file:///home/fedora/development/x86_64/os/repodata/repomd.xml ...OK
Retrieving file:///home/fedora/updates/11/x86_64/repodata/repomd.xml ...OK
Retrieving file:///home/fedora/updates/testing/11/x86_64/repodata/repomd.xml ...OK
Retrieving file:///home/fedora/free/fedora/development/x86_64/os/repodata/repomd.xml ...OK
Retrieving file:///home/fedora/nonfree/fedora/development/x86_64/os/repodata/repomd.xml ...OK
Comment 9 Bruno Wolff III 2009-05-15 16:55:03 EDT
Created attachment 344233 [details]
livecd-creator output using pykickstart-1.52-2.fc11
Comment 10 Jeremy Katz 2009-05-18 15:08:00 EDT
Reproduced with simpler cases too.  Sticking on the blocker list as it blocks building the release
Comment 11 Chris Lumens 2009-05-18 17:33:19 EDT
This should be fixed in the next build of pykickstart, which is coming right up.
Comment 12 Bruno Wolff III 2009-05-18 17:56:39 EDT
I am testing it now. It did use the specified size, so I think it will work.
I'll add another update when it has finished. I won't get a chance to boot the image for a while, so it probably isn't worth waiting for that to close the bug if otherwise things look good.
Comment 13 Bruno Wolff III 2009-05-18 19:48:16 EDT
It ran to completion and produced a reasonably sized iso file.
There were some error messages after ut wrote the file. I suspect this might be related to hung loop devices from last week's testing.
Comment 14 Bruno Wolff III 2009-05-19 00:23:55 EDT
At home I am not getting the iso file. fsck is failing. I think this is a separate bug. So this one can probably be closed.
I'll file another one (against livecd-tools) after I try another build with a modified ks file.
Comment 15 Bruno Wolff III 2009-05-19 14:41:32 EDT
Since it has been confirmed the other issue is a different known bug and not related to the original reported problem and the original problem seems to be fixed and it has made it to rawhide on at least some mirrors, I am closing this.

Note You need to log in before you can comment on or make changes to this bug.