Bug 501023 - gnome-terminal wants to confuse you about installing a font
gnome-terminal wants to confuse you about installing a font
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 10:46 EDT by Dan Winship
Modified: 2009-11-17 07:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 07:50:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2009-05-15 10:46:19 EDT
I was told that gnome-terminal wants to install a font, it had a nice dialog explaining why, and ended with "Do you want to install this font?" Then the options it gave me were "Close" and "Search". These are not meaningful responses to the question it asked. They should be "No" and "Yes", or else the question should be changed.
Comment 1 Behdad Esfahbod 2009-05-15 16:23:22 EDT
This is packagekit.  I wasn't happy about the dialog either.  Lets see what Richard can do.

In my experience it also took a bit too long to show the dialog, and then the search said no fonts matched.  Ideally it should only show the dialog if there exists fonts to install.  And should query that from the local cache (even if it's two months old, who cares?) and be fast...
Comment 2 Bug Zapper 2009-06-09 11:53:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Steven M. Parrish 2009-07-21 21:37:23 EDT
Ping?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Richard Hughes 2009-07-22 05:23:56 EDT
(In reply to comment #0)
> They should be "No" and "Yes", or else the question should be changed.  

The question was changed.

(In reply to comment #1)
> In my experience it also took a bit too long to show the dialog, and then the
> search said no fonts matched.  Ideally it should only show the dialog if there
> exists fonts to install.  And should query that from the local cache (even if
> it's two months old, who cares?) and be fast...  

Right, so we need some sort of caching. We've got sqlite caches in the daemon for other stuff, so this is no big problem. How do I get a list of all packages that have a :lang=* properties? I'm guessing we have to tweak the API so that we can get all provides of a certain type.

I also think we have to be a bit careful about caching cached data, and maybe should look at why yum takes so long to return results. If we just cache when a search failed, we also have to be careful that a package isn't then added to the repo that we then ignore.

Ideas welcome.
Comment 5 Dan Winship 2009-07-22 10:48:46 EDT
> Ideas welcome.

It should use a GtkInfoBar (ie, the firefox-style yellow box that slides down from the top of the window) rather than a dialog. Less intrusive.

And it should have a higher threshold for deciding when to run. Most of the time I see it, it's because I'm looking at some binary garbage, and it just so happens that 3 consecutive bytes of it form a UTF-8 character in some totally random script. For letters at least, it should only run if there are a few of them in a row, suggesting there's an actual word in that script written there, not just an accidental random character. For non-letters though, that heuristic might not be appropriate (eg, mathematical characters).
Comment 6 Behdad Esfahbod 2009-07-22 12:58:20 EDT
(In reply to comment #5)

> It should use a GtkInfoBar (ie, the firefox-style yellow box that slides down
> from the top of the window) rather than a dialog. Less intrusive.

That's not possible since the dialog is shown by the gnome-packagekit process.  I still think a notification bubble kind of thing may make more sense.


> And it should have a higher threshold for deciding when to run. Most of the
> time I see it, it's because I'm looking at some binary garbage, and it just so
> happens that 3 consecutive bytes of it form a UTF-8 character in some totally
> random script. For letters at least, it should only run if there are a few of
> them in a row, suggesting there's an actual word in that script written there,
> not just an accidental random character. For non-letters though, that heuristic
> might not be appropriate (eg, mathematical characters).  

If we only show the dialog if fonts *are* available, it would be a lot less annoying.
Comment 7 Steven M. Parrish 2009-09-12 19:05:12 EDT
Ping?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Behdad Esfahbod 2009-09-14 12:15:00 EDT
https://bugzilla.gnome.org/show_bug.cgi?id=593424
Comment 9 Richard Hughes 2009-11-17 07:50:23 EST
commit a8113a8b2abe2900b1ab87f3a79c7f1247e0b2a4
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Nov 17 12:49:25 2009 +0000

    Add a GConf key to add program exec names to ignore all DBus requests from. Fixes rh#501023

Note You need to log in before you can comment on or make changes to this bug.