Bug 501029 - winecfg fails to connect to mount manager
winecfg fails to connect to mount manager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 10:58 EDT by jeremy boyd
Modified: 2009-07-20 10:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 10:41:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeremy boyd 2009-05-15 10:58:09 EDT
Description of problem: using after creating ~/.wine directory with winecfg the drives tab in winecfg gives this message. "Failed to connect to the mount manager, the drive configuration cannot be edited". this is not a problem for executing programs but for instance after installing Photoshop CS2 the program won't run because there is "no room left on the hard drive".


Version-Release number of selected component (if applicable):1.1.18-1


How reproducible:always


Steps to Reproduce:
1. install wine
2. create .wine directory with winecfg
3.
  
Actual results: c drive is not mapped by wine


Expected results:c drive should be available by wine programs


Additional info:
Comment 1 Bug Zapper 2009-06-09 11:53:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 S.A. Hartsuiker 2009-06-13 18:46:16 EDT
This seems to rebuild to the proper ~/.wine/system.reg file:

wine rundll32 setupapi.dll,InstallHinfSection DefaultInstall 128 /usr/share/wine/wine.inf

All of that belongs on one commandline.
From what I have seen the MountMngr section (among others?) is missing from the ~/.wine/system.reg file.
The above command adds more things like the %ProgramFiles%, etc environmentvariables that are also missing.
Comment 3 S.A. Hartsuiker 2009-06-13 18:54:41 EDT
In case anyone wonders.
The commandline from my previous post comes from the top of the tools/wine.inf.in
file from the wine git repo checkout from winehq.com:

http://wiki.winehq.org/GitWine#head-bc3ee0bfecc17d220da733af4d8ab1154861c7c9
Comment 4 jeremy boyd 2009-06-14 12:24:02 EDT
the problem was not with wine but i had some permission issues with my home folder. when istalling fedora i mounted a drive in my home folder so there were issues. i've re-installed fedora and it works fine.
Comment 5 S.A. Hartsuiker 2009-07-20 07:41:46 EDT
The problem no longer occurs for me with a fresh install of F11 and wine 1.1.23-1.fc11. I think it may have had something to do (in my case at least) with also having codeweaver's version of wine installed.

Can this bug be closed now, since both Jeremy and myself no longer have the problem?
Comment 6 Andreas Bierfert 2009-07-20 10:41:51 EDT
Sure. Thanks for reporting back.

Note You need to log in before you can comment on or make changes to this bug.