Bug 501057 - KeyError: 'mapper/VolGroup00-LogVol00'
KeyError: 'mapper/VolGroup00-LogVol00'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:5e5d0cb94a407bb88...
: CommonBugs, Reopened
: 527875 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 14:05 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 10:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jlaska: fedora_requires_release_note?


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (94.91 KB, text/plain)
2009-05-15 14:05 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (385.91 KB, text/plain)
2009-05-28 06:06 EDT, Vladimir Benes
no flags Details
Attached traceback automatically from anaconda. (179.25 KB, text/plain)
2009-06-10 10:54 EDT, Christian
no flags Details
Attached traceback automatically from anaconda. (332.86 KB, text/plain)
2009-06-11 16:55 EDT, Kevin Constantine
no flags Details
Attached traceback automatically from anaconda. (284.88 KB, text/plain)
2009-06-12 07:10 EDT, Donald Edward
no flags Details
Attached traceback automatically from anaconda. (199.34 KB, text/plain)
2009-06-13 04:33 EDT, sabari
no flags Details
Attached traceback automatically from anaconda. (552.23 KB, text/plain)
2009-06-15 18:17 EDT, Raymond Chace
no flags Details
Attached traceback automatically from anaconda. (98.79 KB, text/plain)
2009-06-18 15:59 EDT, Bob Peers
no flags Details
Attached traceback automatically from anaconda. (220.16 KB, text/plain)
2009-06-25 09:37 EDT, Whorehay
no flags Details
Attached traceback automatically from anaconda. (534.70 KB, text/plain)
2009-06-26 12:06 EDT, bctrainers
no flags Details
Attached traceback automatically from anaconda. (221.84 KB, text/plain)
2009-06-29 04:09 EDT, Ondrej EDA Seda
no flags Details
Attached traceback automatically from anaconda. (286.57 KB, text/plain)
2009-06-30 22:37 EDT, Randall Weytens
no flags Details
Attached traceback automatically from anaconda. (273.76 KB, text/plain)
2009-07-20 20:21 EDT, blacflame
no flags Details
Attached traceback automatically from anaconda. (436.44 KB, text/plain)
2009-07-26 02:48 EDT, David Allen
no flags Details
Attached traceback automatically from anaconda. (370.17 KB, text/plain)
2009-08-11 03:38 EDT, Dagan McGregor
no flags Details
Attached traceback automatically from anaconda. (221.67 KB, text/plain)
2009-09-09 16:00 EDT, sebastiangasparetti
no flags Details
Attached traceback automatically from anaconda. (275.34 KB, text/plain)
2009-09-10 16:38 EDT, jah
no flags Details
Attached traceback automatically from anaconda. (177.10 KB, text/plain)
2009-09-16 15:51 EDT, Nathan Belomy
no flags Details
Attached traceback automatically from anaconda. (305.02 KB, text/plain)
2009-09-18 00:59 EDT, Joachim Frieben
no flags Details
Attached traceback automatically from anaconda. (345.08 KB, text/plain)
2009-09-25 11:33 EDT, clooch01
no flags Details
Attached traceback automatically from anaconda. (224.97 KB, text/plain)
2009-10-04 09:41 EDT, Gabriele Pohl
no flags Details
Attached traceback automatically from anaconda. (288.98 KB, text/plain)
2009-10-04 21:09 EDT, Mark Leone
no flags Details

  None (edit)
Description James Laska 2009-05-15 14:05:26 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.52 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/osbootwidget.py", line 267, in editOther
    (oldshort, oldlong, oldisroot) = self.imagelist[oldDevice]
  File "/usr/lib/anaconda/iw/osbootwidget.py", line 334, in editEntry
    self.editOther(dev, label, isDefault, isRoot)
KeyError: 'mapper/VolGroup00-LogVol00'
Comment 1 James Laska 2009-05-15 14:05:30 EDT
Created attachment 344211 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-05-15 14:07:51 EDT
= Steps to reproduce = 
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_Upgrade_Update_Bootloader

 * At the bootloader config screen, select the configured boot target
 * Select 'Edit'
 * Click 'OK'
Comment 3 Chris Lumens 2009-05-18 17:24:21 EDT
Does updates=http://clumens.fedorapeople.org/501057.img fix things?  Does it break anything else?  That's the worrisome part.
Comment 4 James Laska 2009-05-19 16:38:10 EDT
This appears to address the reported traceback.
Comment 5 James Laska 2009-05-19 16:49:02 EDT
Adding release_note? flag to track noting this issue in the "Fedora 11 Common Bugs" page
Comment 6 Chris Lumens 2009-05-19 16:49:55 EDT
This will be fixed in the next build of anaconda, though as we discussed in IRC this is not a blocker issue.  So we should document it in a release note.
Comment 7 Adam Williamson 2009-05-25 16:47:47 EDT
Common Issues is appropriate for this as it's a bug, not an intentional change. I'm happy to write a Common Issues note, but - more details on the problem would be good. Is there a workaround for this, or is the workaround just "Don't hit Edit on the configured boot target at the bootloader config screen"?
Comment 8 James Laska 2009-05-26 09:26:33 EDT
Common bug entry added at https://fedoraproject.org/wiki/Common_F11_bugs#501057
Comment 9 Adam Williamson 2009-05-27 00:42:59 EDT
james: when adding a common bugs entry, please set the CommonBugs keyword (and put the direct link URL in the whiteboard where appropriate, but on this bug it's already being used for something else...)
Comment 10 Vladimir Benes 2009-05-28 06:06:10 EDT
Created attachment 345722 [details]
Attached traceback automatically from anaconda.
Comment 11 Christian 2009-06-10 09:48:35 EDT
This happens on "fresh" installs too. Not just upgrades. This happened to me on 3 separate machines doing fresh installs on June 9th 2009.
Comment 12 Christian 2009-06-10 10:54:35 EDT
Created attachment 347232 [details]
Attached traceback automatically from anaconda.
Comment 13 Kevin Constantine 2009-06-11 16:55:06 EDT
Created attachment 347472 [details]
Attached traceback automatically from anaconda.
Comment 14 Donald Edward 2009-06-12 07:10:22 EDT
Created attachment 347535 [details]
Attached traceback automatically from anaconda.
Comment 15 sabari 2009-06-13 04:33:33 EDT
Created attachment 347723 [details]
Attached traceback automatically from anaconda.
Comment 16 Gilboa Davara 2009-06-15 06:53:47 EDT
Seeing the same. F11 release x86_64 DVD on IBM 3950M2.
Reopening.

Serial console log. (No network connection, so I couldn't upload the exception log)
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/osbootwidget.py", line 267, in editOther
    (oldshort, oldlong, oldisroot) = self.imagelist[oldDevice]
  File "/usr/lib/anaconda/iw/osbootwidget.py", line 334, in editEntry
    self.editOther(dev, label, isDefault, isRoot)
KeyError: 'mapper/VolRoot-LogFC'

- Gilboa
Comment 17 Gilboa Davara 2009-06-15 06:55:05 EDT
Please ignore. Just saw the it was fixed post-release and well documented.
My mistake, please re-close.

- Gilboa
Comment 18 Raymond Chace 2009-06-15 18:17:29 EDT
Created attachment 348020 [details]
Attached traceback automatically from anaconda.
Comment 19 Bob Peers 2009-06-18 15:59:57 EDT
Created attachment 348549 [details]
Attached traceback automatically from anaconda.
Comment 20 Whorehay 2009-06-25 09:37:28 EDT
Created attachment 349400 [details]
Attached traceback automatically from anaconda.
Comment 21 bctrainers 2009-06-26 12:06:29 EDT
Created attachment 349570 [details]
Attached traceback automatically from anaconda.
Comment 22 Ondrej EDA Seda 2009-06-29 04:09:36 EDT
Created attachment 349754 [details]
Attached traceback automatically from anaconda.
Comment 23 Randall Weytens 2009-06-30 22:37:24 EDT
Created attachment 350048 [details]
Attached traceback automatically from anaconda.
Comment 24 blacflame 2009-07-20 20:21:19 EDT
Created attachment 354406 [details]
Attached traceback automatically from anaconda.
Comment 25 David Allen 2009-07-26 02:48:40 EDT
Created attachment 355180 [details]
Attached traceback automatically from anaconda.
Comment 26 Dagan McGregor 2009-08-11 03:38:14 EDT
Created attachment 356986 [details]
Attached traceback automatically from anaconda.
Comment 27 sebastiangasparetti 2009-09-09 16:00:36 EDT
Created attachment 360333 [details]
Attached traceback automatically from anaconda.
Comment 28 jah 2009-09-10 16:38:53 EDT
Created attachment 360570 [details]
Attached traceback automatically from anaconda.
Comment 29 jah 2009-09-10 16:50:31 EDT
Comment on attachment 360570 [details]
Attached traceback automatically from anaconda.

Ah, good.  So don't edit anything on the installation/boot loader screen and all will be well.
Comment 30 Nathan Belomy 2009-09-16 15:51:42 EDT
Created attachment 361361 [details]
Attached traceback automatically from anaconda.
Comment 31 Joachim Frieben 2009-09-18 00:59:13 EDT
Created attachment 361593 [details]
Attached traceback automatically from anaconda.
Comment 32 clooch01 2009-09-25 11:33:16 EDT
Created attachment 362687 [details]
Attached traceback automatically from anaconda.
Comment 33 Gabriele Pohl 2009-10-04 09:41:20 EDT
Created attachment 363598 [details]
Attached traceback automatically from anaconda.
Comment 34 Mark Leone 2009-10-04 21:09:18 EDT
Created attachment 363628 [details]
Attached traceback automatically from anaconda.
Comment 35 Chris Lumens 2009-10-08 09:24:54 EDT
*** Bug 527875 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.