Bug 50106 - xauth: no such file or directory
xauth: no such file or directory
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openssh (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 17:27 EDT by Bojan Smojver
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-11 08:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2001-07-26 17:27:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.7 i686)

Description of problem:
When logging on to a remote machine which doesn't have X Windows installed,
the following error message appears:

sh: /usr/X11R6/bin/xauth: No such file or directory

while it should probably just silently skip this step since X is not
installed.

RPM: openssh-2.9p2-3

How reproducible:
Always

Steps to Reproduce:
1.  Use OpenSSH to log on to a remote machine that doesn't have X
2.
3.
	

Actual Results:  sh: /usr/X11R6/bin/xauth: No such file or directory

Expected Results:  Should silently ignore xauth?

Additional info:
Comment 1 Michael Tokarev 2001-08-11 08:44:17 EDT
This is not ssh problem per se.  It is a pam problem
(pam_xauth module) -- it should not call xauth if there
is no such program installed.

But.  It is a bug in XFree packages: xauth must be in
XFree-libs, not in XFree.  Reason is that many programs
(e.g. emacs, xterm etc) doesn't need to have local x server,
but needs xlib and xauth (and some more control programs)
to operate.  xlib iteslf is available, but xauth is only
in xserver package.  So I think this bug should be redirected
to xfree package...  BTW, it may be a good idea to include
another subpackage for xfree, e.g. xfree-basic-tools, if
xauth&co doesn't belongs to xlibs.
Comment 2 Nalin Dahyabhai 2001-09-06 08:51:18 EDT
sshd doesn't use pam_xauth -- it's actually trying to run xauth as part of the
process of setting up a session for the user.  Anyhow, this bug should be fixed
again as of 2.9p2-7 and later.  Thanks!
Comment 3 Mike A. Harris 2002-05-29 22:49:14 EDT
I've just split out xauth into a separate subpackage of XFree86 for now
called XFree86-xauth, and it should appear in rawhide within the next week.

Note You need to log in before you can comment on or make changes to this bug.