Bug 501085 - Can't find backintime as a backup application in package managers
Can't find backintime as a backup application in package managers
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: backintime (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Simon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 18:28 EDT by Emanuele Bellini
Modified: 2009-06-15 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9.26-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 22:08:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emanuele Bellini 2009-05-15 18:28:52 EDT
Description of problem:
I was searching for a backup application (typing "backup" in the search folder), I couldn't find backintime because it's not written it is a backup system.


Version-Release number of selected component (if applicable):
0.9.22-2


Steps to Reproduce:
1.Open gnome-package-manager or Yum Extender
2.Search "backup"
  
Actual results:
I can't find backintime.

Expected results:
I should have it as a result of the query.
Comment 1 Christoph Wickert 2009-05-15 20:03:51 EDT
Two different problems here:
1. gpk-application does not search the summary field but only the package name. We cannot fix this here, please file a bug against gnome-packagekit if there isn't one already.
2. The summaries for the backintime packages are not really good and should be reworked to contain the word "backup".
Comment 2 Emanuele Bellini 2009-05-16 05:20:08 EDT
Mmm, I was talking about the latter problem. About the former, gpk-application  can search in the summary, but it isn't the default setting and, first of all, if you don't know how to change that setting you have to search in the web to understand it or to use Yum Extender. I'm going to report that too.
Comment 3 Simon 2009-05-17 08:46:27 EDT
acceptable for you?

--- current-backintime.spec	2009-05-12 19:12:55.000000000 +0200
+++ new-backintime.spec	2009-05-17 14:29:54.000000000 +0200
@@ -1,6 +1,6 @@
 Name:            backintime
 Version:         0.9.24
-Release:         2%{?dist}
+Release:         3%{?dist}
 Summary:         Simple backup system 
 
 Group:           Applications/Archiving
@@ -22,7 +22,7 @@
 
 
 %package         common
-Summary:         Common files for %{name}
+Summary:         Common files for the %{name}, a simple backup system
 Group:           Applications/Archiving
 Requires:        python
 Requires:        rsync
@@ -30,11 +30,15 @@
 
 
 %description     common
+Back In Time is a simple backup system for Linux inspired from 
+“flyback project” and “TimeVault”. The backup is done by taking 
+snapshots of a specified set of directories.
+
 This package contains non GUI files used by different GUI fontends.
 
 
 %package         gnome
-Summary:         Frontend for %{name}
+Summary:         Frontend for %{name}, a simple backup system
 Group:           Applications/Archiving
 Requires:        %{name}-common = %{version}-%{release}
 Requires:        pygtk2-libglade
@@ -44,11 +48,15 @@
 
 
 %description     gnome
+Back In Time is a simple backup system for Linux inspired from 
+“flyback project” and “TimeVault”. The backup is done by taking 
+snapshots of a specified set of directories.
+
 Gnome frontend for %{name}
 
 
 %package         kde
-Summary:         Frontend for %{name}
+Summary:         Frontend for %{name}, a simple backup system
 Group:           Applications/Archiving
 Requires:        %{name}-common = %{version}-%{release}
 Requires:        xorg-x11-utils
@@ -57,6 +65,10 @@
 
 
 %description     kde
+Back In Time is a simple backup system for Linux inspired from 
+“flyback project” and “TimeVault”. The backup is done by taking 
+snapshots of a specified set of directories.
+
 KDE frontend for %{name}
 
 
@@ -225,6 +237,9 @@
 
 
 %changelog
+* Sun May 17 2009 Simon Wesp <cassmodiah@fedoraproject.org> - 0.9.24-3
+- RHBZ #501085
+
 * Tue May 12 2009 Simon Wesp <cassmodiah@fedoraproject.org> - 0.9.24-2
 - LP #375113
Comment 4 Christoph Wickert 2009-05-17 09:32:31 EDT
(In reply to comment #3)
>  %package         gnome
> -Summary:         Frontend for %{name}
> +Summary:         Frontend for %{name}, a simple backup system

BTW: I asked you to use "KDE frontend" and "GNOME frontend" during review.
Comment 5 Simon 2009-05-17 10:36:53 EDT
--- current-backintime.spec	2009-05-12 19:12:55.000000000 +0200
+++ new-backintime.spec	2009-05-17 16:34:30.000000000 +0200
@@ -1,6 +1,6 @@
 Name:            backintime
 Version:         0.9.24
-Release:         2%{?dist}
+Release:         3%{?dist}
 Summary:         Simple backup system 
 
 Group:           Applications/Archiving
@@ -22,7 +22,7 @@
 
 
 %package         common
-Summary:         Common files for %{name}
+Summary:         Common files for the %{name}, a simple backup system
 Group:           Applications/Archiving
 Requires:        python
 Requires:        rsync
@@ -30,11 +30,15 @@
 
 
 %description     common
+Back In Time is a simple backup system for Linux inspired from 
+“flyback project” and “TimeVault”. The backup is done by taking 
+snapshots of a specified set of directories.
+
 This package contains non GUI files used by different GUI fontends.
 
 
 %package         gnome
-Summary:         Frontend for %{name}
+Summary:         Gnome-frontend for %{name}, a simple backup system
 Group:           Applications/Archiving
 Requires:        %{name}-common = %{version}-%{release}
 Requires:        pygtk2-libglade
@@ -44,11 +48,15 @@
 
 
 %description     gnome
+Back In Time is a simple backup system for Linux inspired from 
+“flyback project” and “TimeVault”. The backup is done by taking 
+snapshots of a specified set of directories.
+
 Gnome frontend for %{name}
 
 
 %package         kde
-Summary:         Frontend for %{name}
+Summary:         KDE-frontend for %{name}, a simple backup system
 Group:           Applications/Archiving
 Requires:        %{name}-common = %{version}-%{release}
 Requires:        xorg-x11-utils
@@ -57,6 +65,10 @@
 
 
 %description     kde
+Back In Time is a simple backup system for Linux inspired from 
+“flyback project” and “TimeVault”. The backup is done by taking 
+snapshots of a specified set of directories.
+
 KDE frontend for %{name}
 
 
@@ -225,6 +237,9 @@
 
 
 %changelog
+* Sun May 17 2009 Simon Wesp <cassmodiah@fedoraproject.org> - 0.9.24-3
+- RHBZ #501085
+
 * Tue May 12 2009 Simon Wesp <cassmodiah@fedoraproject.org> - 0.9.24-2
 - LP #375113
Comment 6 Emanuele Bellini 2009-05-17 14:40:52 EDT
I don't know if it could be confusing to call it a "simple backup system" since there's the other utility sbackup which has it as its own name...! What's the difference between the two? I haven't tried backintime but I'm using sbackup, I think the main difference is that the former lets you retrieve past versions of the files so you can use it when your computer isn't broken, whereas the latter makes a backup and lets you restore all the files. Am I wrong?
Comment 7 Emanuele Bellini 2009-05-17 15:02:49 EDT
I don't know if it could fit: "an easy to use backup system featuring file versioning"
It doesn't sound good, so I hope you have a better idea!
Comment 8 Simon 2009-05-17 15:05:31 EDT
too long for a summary incl. KDE/GNOME frontend
Comment 9 Christoph Wickert 2009-05-17 15:18:28 EDT
"Simple backup system" is a pretty generic description that is taken from upstream's descripton. I have to admit that it overlaps a little with sbackup, but sbackup stands for "Simple backup suite" and suite != system.

How about ".... a simple backup utility" or ".... backup program"?
Comment 10 Simon 2009-05-17 15:30:35 EDT
simple backup tool
http://backintime.le-web.org/
Comment 11 Emanuele Bellini 2009-05-18 08:13:37 EDT
No better than a citation from its site... Moreover, whereas suite != system for a compiler (I mean that "system" could be intended as suite of programs), tool != suite for a human too!!!
I'm joking, at this point that could be OK!
Comment 12 Fedora Update System 2009-05-23 04:32:10 EDT
backintime-0.9.24-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/backintime-0.9.24-3.fc11
Comment 13 Fedora Update System 2009-05-23 09:42:28 EDT
backintime-0.9.26-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/backintime-0.9.26-1.fc11
Comment 14 Fedora Update System 2009-05-23 09:43:14 EDT
backintime-0.9.26-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/backintime-0.9.26-1.fc10
Comment 15 Fedora Update System 2009-05-25 17:10:41 EDT
backintime-0.9.26-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update backintime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5349
Comment 16 Fedora Update System 2009-05-25 17:14:10 EDT
backintime-0.9.26-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update backintime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5385
Comment 17 Fedora Update System 2009-05-25 17:23:05 EDT
backintime-0.9.24-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update backintime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5362
Comment 18 Fedora Update System 2009-06-15 22:08:09 EDT
backintime-0.9.26-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-06-15 22:40:35 EDT
backintime-0.9.26-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.