Bug 50110 - xcin rpmlint errors -- invalid lc messages dir?
Summary: xcin rpmlint errors -- invalid lc messages dir?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xcin (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Nakai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-26 21:56 UTC by Panic
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 18:54:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Panic 2001-07-26 21:56:09 UTC
Description of Problem:

xcin fails the rpmlint testing, with these warnings and errors:

W: xcin conffile-without-noreplace-flag /etc/chinese/xcin/xcinrc
W: xcin non-conffile-in-etc /etc/X11/wmconfig/xcin
E: xcin invalid-lc-messages-dir /usr/share/locale/zh_TW/LC_MESSAGES/xcin.mo
W: xcin file-not-in-%lang /usr/share/locale/zh_TW/LC_MESSAGES/xcin.mo

This attracted my attention because the E: error doesn't make any sense --
I *know* that is a valid LC_MESSAGES directory, and the file goes in fine.
 Some missing settings maybe?  Related to that last warning?

How Reproducible:

Always

Steps to Reproduce:
1. run rpmlint against the xcin package
2. 
3. 

Actual Results:

Strange errors.

Expected Results:

Minor errors and warnings, or no error messages.

Additional Information:

Comment 1 Glen Foster 2001-07-30 18:42:13 UTC
Bill says this isn't really invalid -- we should filter these out somehow...
Tim?

Comment 2 Nakai 2001-07-30 18:50:31 UTC
> W: xcin conffile-without-noreplace-flag /etc/chinese/xcin/xcinrc

Those config files should be with config(noreplace) ?

> W: xcin non-conffile-in-etc /etc/X11/wmconfig/xcin


> E: xcin invalid-lc-messages-dir /usr/share/locale/zh_TW/LC_MESSAGES/xcin.mo
> W: xcin file-not-in-%lang /usr/share/locale/zh_TW/LC_MESSAGES/xcin.mo
These errors are fixed with xcin-2.5.2.3-5

Comment 3 Tim Powers 2001-07-30 18:54:00 UTC
Yes, I think it's already filtered out in our internal filter.

This does need to be fixed, we use applnk, not wmconfig files now:

W: xcin non-conffile-in-etc /etc/X11/wmconfig/xcin

It needs to be converted to an applnk style file, and the
/etc/X11/wmconfig/xcin file should no longer be included in the package.

Tim

Comment 4 Nakai 2001-08-07 14:39:07 UTC
Fixed in xcin-2.5.2.3-6



Note You need to log in before you can comment on or make changes to this bug.