This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 50113 - Add 'References:' header to mails
Add 'References:' header to mails
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 18:30 EDT by Enrico Scholz
Modified: 2007-04-18 12:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.18
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 13:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-07-26 18:30:14 EDT
It would be nice if mails sent by bugzilla can be grouped by MUAs into
threads. This needs only small changes in bugzilla (I guess ;)) and can be
reached by adding a 'References:' header pointing to the [New]-mail. 

You can add an extra column to the database storing the msg-id of the
[New]-mail, but it would be more easy if this mail gets a msg-id like 

    Message-ID: <bugzilla-#bugid@bugzilla.redhat.com>

which should be an unique value. [Changed] mails don't need a special
msg-id; it can be still assigned by the MTA. They need only a header like

    References: <bugzilla-#bugid@bugzilla.redhat.com>
Comment 1 Aleksey Nogin 2002-10-25 15:24:21 EDT
This schema would only work is the "New" message is still around. What if you
have deleted it? What if you have added yourself to the CC list and never saw
the "New" message?

My proposal is in each mail to include:

Message-Id: <bugzilla-bugid-serial@bugzilla.redhat.com>
References: <bugzilla-bugid-"serial - 1"@bugzilla.redhat.com>

(or even:
References: <bugzilla-bugid-"serial - 1"@bugzilla.redhat.com>
<bugzilla-bugid-"serial - 2"@bugzilla.redhat.com> <bugzilla-bugid-"serial -
3"@bugzilla.redhat.com> 
)

where "serial" is the number of bugmail that were sent for this bug. This way
every bugmail will be filed in a MUA as a response to the previous bugmail (or
several previous bugmails) from the same bug, which is what it usually is.
Comment 2 David Lawrence 2002-12-13 17:03:49 EST
How would I obtain this "serial" number based on how Bugzilla is currently
sending out mail. Currently it opens a pipe to /usr/lib/sendmail -t and cats a
preformatted message to the pipe. Is there way to retrieve the serial number? I
will admit to not being a mail expert.
Comment 3 Enrico Scholz 2002-12-13 17:27:17 EST
The serial number is the count of comments; the initial report has a serial of
'0'. This value is already in use (e.g. in 

| https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=50113#c2
                                                              ~

), is available inside bugzilla and has nothing to do with the mailing-process.
Comment 4 Enrico Scholz 2002-12-13 17:44:43 EST
Special messages which do depend on a new comment (e.g. changed dependencies)
should not have a Message-Id given by bugzilla. (Or bugzilla should use an
internal counter to create unique Message-Id's; but because sendmail creates
good Message-Id's when the message does not contain a such one already, this
will be unnecessary work IMHO).


I am not sure if 

| References: <bugzilla-<bugid>-0@....>

or

| References: <bugzilla-<bugid>-<# of comments - 1>@...>

should be used in this case; I would prefer the first version.
Comment 5 Aleksey Nogin 2002-12-13 18:28:25 EST
Re: comment #4.

I actually think that *both* should be used - e.g.

References: <bugzilla-<bugid>-0@....>, <bugzilla-<bugid>-<# of comments - 1>@...>

(or may be even 3 or 4 references - 0 and previous 2 or 3).

The reason is that
- user may have deleted the first message
- CC users may have never gotten the first message at all.
Comment 6 David Lawrence 2005-08-12 11:39:17 EDT
revisiting, since In-Reply-To: bugzilla-<bugid>@redhat.com doesnt seem to be
suiting everyone due to MUA differences.
Comment 7 David Lawrence 2005-08-23 13:36:17 EDT
Changes have been made to fix this problem. Please reopen this bug if not the
case for you.

Note You need to log in before you can comment on or make changes to this bug.