Bug 501139 - thunderbird often hangs on close
thunderbird often hangs on close
Status: CLOSED DUPLICATE of bug 501427
Product: Fedora
Classification: Fedora
Component: gtk-qt-engine (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 19:20 EDT by Rex Dieter
Modified: 2009-08-12 09:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-12 09:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of thunderbird not closing... (45.79 KB, text/plain)
2009-05-18 11:58 EDT, Nathanael Noblet
no flags Details

  None (edit)
Description Rex Dieter 2009-05-16 19:20:40 EDT
Since upgrading to
thunderbird-3.0-2.4.b3pre.hg.6a6386c16e98.fc11

thunderbird frequently hangs on close/quit, leaving a thunderbird-bin process pegging the cpu.  Subsequent attempts to run thunderbird then fail, with "thunderbird is already running".

I use thunderbird primarily to read mail to several imap accounts (one is an uw-imap server, anotheris gmail).
Comment 1 Matěj Cepl 2009-05-17 05:08:27 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *thunderbird*

Please also install thunderbird-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install thunderbird

Then run thunderbird with a parameter -g. That will start thunderbird running inside of gdb debugger. Then use command run and do whatever you did to make thunderbird crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

Alternative way is to attach gdb to the hand process

gdb --pid=$(pidof thunderbird-bin)

and then you get gdb prompt where you can run the same backtrace command.

Either of these ways produce usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Rex Dieter 2009-05-17 11:52:46 EDT
xulrunner-1.9.1.-0.20.beta4.f11.x86_64
thunderbird-3.0-2.4.b3pre.hg.6a6386c16e98.fc11.x86_64

I'll work to get a backtrace here in a bit.
Comment 3 Nathanael Noblet 2009-05-18 11:58:51 EDT
Created attachment 344465 [details]
Strace of thunderbird not closing...
Comment 4 Nathanael Noblet 2009-05-18 12:37:10 EDT
#0  0x0000003214c0df5b in read () from /lib64/libpthread.so.0
#1  0x00000032a5e0a490 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00000032a5e0a9a8 in xcb_poll_for_event () from /usr/lib64/libxcb.so.1
#3  0x0000003f63c4cfc5 in ?? () from /usr/lib64/libX11.so.6
#4  0x0000003f63c4d726 in _XEventsQueued () from /usr/lib64/libX11.so.6
#5  0x0000003f63c35ccd in XPending () from /usr/lib64/libX11.so.6
#6  0x0000003f6684b773 in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
#7  0x000000360923a86a in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#8  0x000000360923ac8a in ?? () from /lib64/libglib-2.0.so.0
#9  0x000000360923b14b in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#10 0x00007fffef1ceb79 in nsBaseAppShell::DoProcessNextNativeEvent (this=0x6, mayWait=-138063692) at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:151
#11 0x00007fffef1cec96 in nsBaseAppShell::OnProcessNextEvent (this=0x7ffff7b4aee0, thr=0x7ffff7c52e00, mayWait=1, recursionDepth=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:278
#12 0x00000037b8a6cd48 in nsThread::ProcessNextEvent (this=0x7ffff7c52e00, mayWait=1, result=0x7fffffffd7bc) at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:497
#13 0x00000037b8a3dd65 in NS_ProcessNextEvent_P (thread=0x6, mayWait=1) at nsThreadUtils.cpp:227
#14 0x00000037b8a6d0d6 in nsThread::Shutdown (this=0x7fffe1ec63a0) at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:465
#15 0x00000037b8a6df82 in nsThreadManager::Shutdown (this=0x37b8cc3880) at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThreadManager.cpp:144
#16 0x00000037b8a40b01 in NS_ShutdownXPCOM_P (servMgr=0x7ffff7c87528) at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/build/nsXPComInit.cpp:779
#17 0x00000037b8215631 in ~ScopedXPCOMStartup (this=0x7fffffffdd30) at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:951
#18 0x00000037b8219743 in XRE_main (argc=<value optimized out>, argv=<value optimized out>, aAppData=<value optimized out>) at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:3341
#19 0x00000000004019bc in main (argc=1, argv=0x7fffffffe0d8) at /usr/src/debug/thunderbird-3.0/mail/app/nsMailApp.cpp:103
Comment 5 Matěj Cepl 2009-05-19 06:06:19 EDT
(In reply to comment #4)
> #0  0x0000003214c0df5b in read () from /lib64/libpthread.so.0
> #1  0x00000032a5e0a490 in ?? () from /usr/lib64/libxcb.so.1
> #2  0x00000032a5e0a9a8 in xcb_poll_for_event () from /usr/lib64/libxcb.so.1

I am sorry, but it is not good backtrace:

a) you have still some missing debuginfos ... please run
debuginfo-install thunderbird again
b) we need WHOLE output of gdb ... from the top to the bottom.
Comment 6 Nathanael Noblet 2009-05-19 11:02:01 EDT
I'm assuming that you didn't get a full debug because I need debuginfo for glibc and friends? I have thunderbird-debuginfo installed...
Comment 7 Rex Dieter 2009-05-19 11:23:14 EDT
nice, today I finally got around to do
debuginfo-install thunderbird

and now it's no longer hanging.  I'll keep an eye on it.
Comment 8 Rex Dieter 2009-05-19 11:31:39 EDT
Shrug, with no amount of coaxing can I reproduce.  Closing for now.
Comment 9 Nathanael Noblet 2009-05-19 16:54:07 EDT
Is this any better?? Still happens for me. I re-rand debuginfo-install thunderbird...

#0  0x0000003214c0df5b in read () from /lib64/libpthread.so.0
#1  0x00000032a5e0a490 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00000032a5e0a9a8 in xcb_poll_for_event () from /usr/lib64/libxcb.so.1
#3  0x0000003f63c4cfc5 in process_responses (dpy=0x6, wait_for_first_event=0, 
    current_error=0x0, current_request=0) at xcb_io.c:115
#4  0x0000003f63c4d726 in _XEventsQueued (dpy=0x7ffff7c54000, 
    mode=<value optimized out>) at xcb_io.c:197
#5  0x0000003f63c35ccd in XPending (dpy=0x7ffff7c54000) at Pending.c:56
#6  0x0000003f6684b773 in gdk_check_xpending () at gdkevents-x11.c:154
#7  gdk_event_prepare (source=<value optimized out>, 
    timeout=<value optimized out>) at gdkevents-x11.c:2322
#8  0x000000360923a86a in IA__g_main_context_prepare (context=0x7ffff7c1a7a0, 
    priority=0x7fffffffd694) at gmain.c:2464
#9  0x000000360923ac8a in g_main_context_iterate (context=0x7ffff7c1a7a0, 
    block=0, dispatch=1, self=<value optimized out>) at gmain.c:2758
#10 0x000000360923b14b in IA__g_main_context_iteration (
    context=0x7ffff7c1a7a0, may_block=0) at gmain.c:2841
#11 0x00007fffef1ceb79 in nsBaseAppShell::DoProcessNextNativeEvent (this=0x6, 
    mayWait=-138063692)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:151
#12 0x00007fffef1cece5 in nsBaseAppShell::OnProcessNextEvent (
    this=0x7ffff7b4aee0, thr=0x7ffff7c52e00, mayWait=0, 
    recursionDepth=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:296
#13 0x00000037b8a6cd48 in nsThread::ProcessNextEvent (this=0x7ffff7c52e00, 
    mayWait=1, result=0x7fffffffd7bc)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:497
#14 0x00000037b8a3dd65 in NS_ProcessNextEvent_P (thread=0x6, mayWait=1)
    at nsThreadUtils.cpp:227
#15 0x00000037b8a6d0d6 in nsThread::Shutdown (this=0x7fffe66a58b0)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:465
#16 0x00000037b8a6df82 in nsThreadManager::Shutdown (this=0x37b8cc3880)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThreadManager.cpp:144
#17 0x00000037b8a40b01 in NS_ShutdownXPCOM_P (servMgr=0x7ffff7c87528)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/build/nsXPComInit.cpp:779
#18 0x00000037b8215631 in ~ScopedXPCOMStartup (this=0x7fffffffdd30)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:951
#19 0x00000037b8219743 in XRE_main (argc=<value optimized out>, 
    argv=<value optimized out>, aAppData=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:3341
#20 0x00000000004019bc in main (argc=1, argv=0x7fffffffe0d8)
    at /usr/src/debug/thunderbird-3.0/mail/app/nsMailApp.cpp:103
Comment 10 Nathanael Noblet 2009-05-19 16:57:25 EDT
and another one seems more apt...

#0  0x00000032140dc886 in __poll (fds=0x7fffe8dd2b00, nfds=10, timeout=0)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x000000360923ae28 in g_main_context_poll () at gmain.c:3091
#2  g_main_context_iterate (context=0x7ffff7c1a7a0, block=0, dispatch=1, 
    self=<value optimized out>) at gmain.c:2773
#3  0x000000360923b14b in IA__g_main_context_iteration (
    context=0x7ffff7c1a7a0, may_block=0) at gmain.c:2841
#4  0x00007fffef1ceb79 in nsBaseAppShell::DoProcessNextNativeEvent (
    this=0x7fffe8dd2b00, mayWait=10)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:151
#5  0x00007fffef1cec96 in nsBaseAppShell::OnProcessNextEvent (
    this=0x7ffff7b4aee0, thr=0x7ffff7c52e00, mayWait=1, 
    recursionDepth=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:278
#6  0x00000037b8a6cd48 in nsThread::ProcessNextEvent (this=0x7ffff7c52e00, 
    mayWait=1, result=0x7fffffffd7bc)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:497
#7  0x00000037b8a3dd65 in NS_ProcessNextEvent_P (thread=0x7fffe8dd2b00, 
    mayWait=1) at nsThreadUtils.cpp:227
#8  0x00000037b8a6d0d6 in nsThread::Shutdown (this=0x7fffe66a58b0)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:465
---Type <return> to continue, or q <return> to quit---
#9  0x00000037b8a6df82 in nsThreadManager::Shutdown (this=0x37b8cc3880)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThreadManager.cpp:144
#10 0x00000037b8a40b01 in NS_ShutdownXPCOM_P (servMgr=0x7ffff7c87528)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/build/nsXPComInit.cpp:779
#11 0x00000037b8215631 in ~ScopedXPCOMStartup (this=0x7fffffffdd30)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:951
#12 0x00000037b8219743 in XRE_main (argc=<value optimized out>, 
    argv=<value optimized out>, aAppData=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:3341
#13 0x00000000004019bc in main (argc=1, argv=0x7fffffffe0d8)
    at /usr/src/debug/thunderbird-3.0/mail/app/nsMailApp.cpp:103
Comment 11 Rex Dieter 2009-05-19 18:53:10 EDT
ok, still reproducible at home on i586 box:

backtrace:

(gdb) backtrace
#0  0x00bbf2ac in nsRunnable::AddRef() () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#1  0x00bf3507 in nsEventQueue::PutEvent(nsIRunnable*) () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#2  0x00bf41e9 in ?? () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#3  0x00bf4371 in ?? () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#4  0x05431f98 in ?? () from /usr/lib/thunderbird-3.0b3pre/components/libwidget_gtk2.so
#5  0x00bf45b3 in ?? () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#6  0x00bbefee in NS_ProcessNextEvent_P(nsIThread*, int) () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#7  0x00bf4998 in ?? () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#8  0x00bf5ad9 in ?? () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#9  0x00bc22dd in NS_ShutdownXPCOM_P () from /usr/lib/thunderbird-3.0b3pre/libxpcom_core.so
#10 0x00a7ee03 in ?? () from /usr/lib/thunderbird-3.0b3pre/libxul.so
#11 0x00a82d93 in XRE_main () from /usr/lib/thunderbird-3.0b3pre/libxul.so
#12 0x0804943e in nsACString_internal::nsACString_internal(char*, unsigned int, unsigned int) ()
#13 0x002d9a66 in __libc_start_main () from /lib/libc.so.6
#14 0x080492a1 in nsACString_internal::nsACString_internal(char*, unsigned int, unsigned int) ()
Comment 12 Rex Dieter 2009-05-19 20:25:44 EDT
bleh, not all the -debuginfo pkgs were installed (yet).

Better now, looks familiar, like comment #10

(gdb) backtrace                                                                                                                              
#0  0x005e9422 in __kernel_vsyscall ()
#1  0x00397276 in *__GI___poll (fds=0x42fff4, nfds=9, timeout=0) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x00665aeb in IA__g_poll (fds=0xb557fd80, nfds=9, timeout=0) at gpoll.c:127
#3  0x00658783 in g_main_context_poll (n_fds=<value optimized out>, fds=<value optimized out>, priority=<value optimized out>,
    timeout=<value optimized out>, context=<value optimized out>) at gmain.c:2761
#4  g_main_context_iterate (n_fds=<value optimized out>, fds=<value optimized out>, priority=<value optimized out>,
    timeout=<value optimized out>, context=<value optimized out>) at gmain.c:2443
#5  0x0065896a in IA__g_main_context_iteration (context=0xb7c17300, may_block=0) at gmain.c:2511
#6  0x010cb4e4 in nsAppShell::ProcessNextNativeEvent (this=0xb7b30e70, mayWait=0)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/gtk2/nsAppShell.cpp:144
#7  0x010e1d80 in nsBaseAppShell::DoProcessNextNativeEvent (this=0xb7b30e70, mayWait=0)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:151
#8  0x010e1ecc in nsBaseAppShell::OnProcessNextEvent (this=0xb7b30e70, thr=0xb7c8b2e0, mayWait=1, recursionDepth=0)
    at /usr/src/debug/thunderbird-3.0/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:278
#9  0x00bf45b3 in nsThread::ProcessNextEvent (this=0xb7c8b2e0, mayWait=1, result=0xbf83e20c)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:497
#10 0x00bbefee in NS_ProcessNextEvent_P (thread=0xfffffdfc, mayWait=1) at nsThreadUtils.cpp:227
#11 0x00bf4998 in nsThread::Shutdown (this=0xabeaa150) at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThread.cpp:465
#12 0x00bf5ad9 in nsThreadManager::Shutdown (this=0xc5bd5c) at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/threads/nsThreadManager.cpp:144
#13 0x00bc22dd in NS_ShutdownXPCOM_P(struct nsIServiceManager *) (servMgr=0xb7cad104)
    at /usr/src/debug/thunderbird-3.0/mozilla/xpcom/build/nsXPComInit.cpp:779
#14 0x00a7ee03 in ScopedXPCOMStartup::~ScopedXPCOMStartup (this=0xbf83e5d4, __in_chrg=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0/mozilla/toolkit/xre/nsAppRunner.cpp:951
#15 0x00a82d93 in XRE_main (argc=1, argv=0xbf83e894, aAppData=0xb7c05640)
#16 0x0804943e in main (argc=1, argv=0xbf83e894) at /usr/src/debug/thunderbird-3.0/mail/app/nsMailApp.cpp:103
Comment 14 Bug Zapper 2009-06-09 11:57:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Milan Kerslager 2009-06-12 03:20:09 EDT
Same here too with F11+updates (thunderbird-3.0-2.3.beta2.fc11.x86_64). Will try to post backtrace when on high bandwidth lane.
Comment 16 Milan Kerslager 2009-06-12 03:42:07 EDT
On my system, it not hangs. It just only stuck for some period of time (~10 sec or more). It seems that it hammer my CPU periodically as my CPU cooling turns on sometimes even it should not (and I'm not able to switch focus to Thunderbird window during this time).
Comment 17 Nathanael Noblet 2009-06-17 16:05:41 EDT
I just updated to F11, and now it doesn't have the same problem anymore. Originally I posted mine with F10+updates-testing version.
Comment 18 Matěj Cepl 2009-06-23 19:12:19 EDT
(In reply to comment #16)
> On my system, it not hangs. It just only stuck for some period of time (~10 sec
> or more). It seems that it hammer my CPU periodically as my CPU cooling turns
> on sometimes even it should not (and I'm not able to switch focus to
> Thunderbird window during this time).  

Milan, can you confirm please comment 17 that this issue has been resolved with F11?

Thank you in advance.
Comment 19 Milan Kerslager 2009-06-24 04:19:26 EDT
Yes. This problem is still present. It sometimes hogg 100% of CPU, it is not possible to switch to its window or change active message, select menu etc. Since it not hang or crash, I'm not sure how to post usable report.
Comment 20 Nathanael Noblet 2009-06-24 14:53:29 EDT
I need to revise my statement about no problems on F11. They went away for a time, and now when I close TB, *sometimes* it stays in the processlist. The window is gone, I don't see it, and if I don't notice I won't know till I try to start it again and it fails since it is already running. On F10+updates-testing, this happened *every* time without fail. Now I'm guessing we're at something like 40% of the time.
Comment 21 J. Randall Owens 2009-08-11 18:24:09 EDT
This is probably the same issue as the Firefox bug #512487, where they finally found that Firefox didn't display the behavior if you changed the Gtk style to something other than "Use my KDE style" or "Qt4".  I changed mine, and Thunderbird finally stopped hanging now.  Before, it was a pretty solid 100% for me.

Are we who have seen this bug, by any chance, all using KDE?
Comment 22 Matěj Cepl 2009-08-11 18:45:26 EDT
(In reply to comment #21)
> This is probably the same issue as the Firefox bug #512487, where they finally
> found that Firefox didn't display the behavior if you changed the Gtk style to
> something other than "Use my KDE style" or "Qt4".  I changed mine, and
> Thunderbird finally stopped hanging now.  Before, it was a pretty solid 100%
> for me.
> 
> Are we who have seen this bug, by any chance, all using KDE?  

Well, the original reporter of this bug certainly does :).

Changing component accordingly.
Comment 23 Rex Dieter 2009-08-12 09:28:55 EDT

*** This bug has been marked as a duplicate of bug 501427 ***

Note You need to log in before you can comment on or make changes to this bug.