Bug 501141 - Images and Frames disappear in sequential printing
Images and Frames disappear in sequential printing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 20:01 EDT by Wolfram Wagner
Modified: 2009-08-31 19:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.1.1-19.1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 19:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files showing the bug (25.72 KB, application/zip)
2009-05-20 07:16 EDT, Wolfram Wagner
no flags Details
easier reproducer (10.72 KB, application/vnd.oasis.opendocument.text)
2009-05-20 08:43 EDT, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 40827 None None None Never

  None (edit)
Description Wolfram Wagner 2009-05-16 20:01:17 EDT
Description of problem:
There are major problems to print images in a sequential letter, if you leave the standard path.
I formatted the template letter using text frames (partially overlapping) and paragraph settings (space above and below paragraph). Then I placed images in that space and they disappeared.

Additionally I had problems with the assistent when I changed to preview mode => it closed the small "back to assistent" window.

Third I lost four times the referenced fields and had to reimport them.

It was terrible, there was only one way to get the result I wanted, by setting the image anchors into text and making space for them using empty lines.

I guess there is a problem to calculate the positions of the frames and images in the copy routine...

How reproducible:


Steps to Reproduce:
1.Use a Calc sheet as datasource for your data fields
2.Create a letter with word and define frames for the address field, for the sender part in letter head and the text. Add an image above and anchor it to the page.
3.Create a text and define different paragraph templates (greeting, body, signature). Signature had some space above to make place for the signature images (PNG), two side on side. (have you noticed, that you can't select more than one image at a time?)
4.Try to print, say yes sequential letter, print to file, something.odt and open it.
  
Actual results:
- images and frames disappear, change their positions

Expected results:
- The template page but with data fields replaced with the actual values.

Additional info:
Contact me if I can be of help!
Comment 1 Caolan McNamara 2009-05-17 17:44:44 EDT
There sounds like quite a few subjective steps here to follow. Is there any point along the line where you are able to save the interim document correctly ? and then restore that document and continue in a few simple steps to generate incorrect output ?
Comment 2 Wolfram Wagner 2009-05-20 07:16:17 EDT
Created attachment 344785 [details]
Files showing the bug

Contains the template for the serial letter, the calc sheet that contains the address data, the image and the resulting printout.
Comment 3 Wolfram Wagner 2009-05-20 07:24:03 EDT
I reproduced the problem right now under WindowsXP and OO 3.0.

Please unpack my example! 

There is a simple calcsheet that contains one "address"
There is the picture that disappears.
There is the template for the serial letter containing the image and two serial fields
and there is the result with disappeared image.

Steps to create serial template:
- Wrote static text
- mark line below image and rename paragraph name to "below"
- right click on "below" paragraph, edit paragraph settings
- set space above paragraph to 10cm
- insert image from file
- shift image with mouse over the space created with paragraph setting
- insert fields, add data source, insert the fields from calc sheet
- CTRL+P => contains serial fields! Print serial letter? YES
- Print to file, give name

==> image disappears.

The similar behavior and more disturbing issues come up, if you use text frames and let them overlap.
There also seem to be a dependance on the place where your anchor things. Anchor on page level seems to be of problem.

Shall I create separate bug reports?

W.
Comment 4 David Tardon 2009-05-20 08:09:08 EDT
It works as expected if I choose 'Save as individual documents' in the 'Mail Merge' dialog. If 'Save as single document' is chosen, the image is not saved.
Comment 5 Caolan McNamara 2009-05-20 08:43:15 EDT
Created attachment 344791 [details]
easier reproducer
Comment 6 Caolan McNamara 2009-05-20 08:45:58 EDT
Open #5 ctrl+a to select all, ctrl+c to copy all, ctrl+n for a new document, ctrl+v to paste. ==> graphic doesn't transfer to new document. right ?
Comment 7 Wolfram Wagner 2009-05-20 09:34:04 EDT
I don't know, if this is the same issue, but the result is the same...
Comment 8 David Tardon 2009-08-21 01:25:13 EDT
Fix checked in to F-10, F-11 and Rawhide. Will be in >=3.0.1-15.5, resp. >=3.1.0-11.6, if there is another update for F-10, resp. F-11, and in >=3.1.1-19.2.
Comment 9 Fedora Update System 2009-08-29 05:41:45 EDT
openoffice.org-3.1.1-19.1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.1.fc11
Comment 10 Fedora Update System 2009-08-31 19:32:06 EDT
openoffice.org-3.1.1-19.1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.